Merekin

Members
  • Content count

    15
  • Joined

  • Last visited

About Merekin

  • Rank
    Member

Profile Information

  • Github
    r-lourical
  1. I'm trying to change the skill tree of a class, but after i modified the skilldb and skill_treedb.conf the skills are appearing in the etc tab of the Skills window. I tried changing the skilltreeview.lub archive, but nothing happened. What file i need to modify to make the new skills appears in the right place?
  2. Replying here because i also want to solve this issue. In my case the skills go to "etc" and i can't level up them. How do i make them go to the first or second class tab? Changing skill_tree.conf or skilltreeview.lub did nothing.
  3. Thanks, but... How did you do it?
  4. I'm trying to customize my server at max, and right now i'm trying to change the skill tree of some classes, but i can't decompile the skilltreeview.lub file. I've already tried a lot of luadec versions and some other programs, without sucess. I'll pass the file if someone wanna try and tell me what method you used. Thanks skilltreeview.lub
  5. Se fosse um problema de incompatibilidade ou de diff não haveria problemas com outros arquivos também? De qualquer forma vou tentar ver algum desses tutoriais atualizados e ver se eu consigo emular sem problemas.
  6. Eu estou tentando configurar um servidor, mas estou tento problemas com o Client. Eu tentei fazer o client de duas formas. A primeira foi de acordo com esse guia, seguindo passo a passo. A única diferença foi que o arquivo de tradução não tinha nenhum iteminfo.lub, e sim iteminfo.lua, mas eu não acho que isso cause o erro. No caso o erro é que o servidor não conecta, embora o clientinfo.xml esteja com as configurações certas o client nem tenta conectar com o servidor. Depois eu tentei denovo, mas seguindo um outro guia de tradução, esse aqui. Mas por esse guia eu também encontro problemas. Quando eu tento abrir o client, esses erros aparecem. Embora sejam muitos erros o jogo ainda funciona normalmente, até onde eu vi, mas eu gostaria de corrigi-los até por ser chato ver isso sempre que se abre o client. Eu não sei onde eu estou errando nos dois casos. Se algum puder me ajudar com qualquer das duas formas ou mesmo com alguma outra forma de traduzir o client (para português talvez?) eu ficaria muito agradecido.
  7. Eu sei que existem alguns servidores que implementaram essa função, porém eu não sei como eles o fizeram ou mesmo se existe somente uma forma. A um tempo atrás eu estava olhando os códigos de classe e sprite para descobrir como fazer isso e eu percebi que existe uma relação "presa" entre o sprite e a classe. Se você mudar o sprite a classe muda, se mudar a classe muda o sprite. O primeiro passo que eu vou tentar assim que conseguir colocar meu emulador pra funcionar normalmente aqui (tive que formatar o computador recentemente...) é ver se eu consegui desfazer esse elo que deixa esses dois status presos um ao outro.
  8. Yes 4144 i was doing a rookie mistake, sorry. Actually the problem is this: Edit: It was a problem in my MySQL server. i reinstalled it and the problem was solved. Thanks for you help and patience. : Client does not support authentication protocol requested by server; consider upgrading MySQL client
  9. Winterfox, my VS was lacking the 14v toolkit, but that wasn't the problem. My servers.exe still can't find the conf files. Does someone know what can be causing this problem? every file is in the conf file in the Hercules folder, as it should be. i literally have no clue... edit: I even checked the source code to be sure.
  10. I'm using VS 17 on W10. it needed some changes to compile the servers. 'll try compiling without redirecting the solutions and test again.
  11. yes. I only changed the password to connect in the Database.
  12. The compiled server is where it was created, in the "Hercules" folder. The same goes for my conf folder. I noticed that the map-server can't even find the scripts_main.conf in the npc folder. I am using a copy of the Hercules folder that i made from the one from git-hub, can it be the problem?
  13. Yeah... Didn't thought about that Winterfox, thanks. Here are some better screenshots. login-server Char-server Map-server
  14. I wasn't getting anything on the logs before but now i saw this: (06/19/2018 17:06:46) [ SQL Error ] : Client does not support authentication protocol requested by server; consider upgrading MySQL client But i just downloaded the latest MySQL. What am i doing wrong here?
  15. I'm new here in the community and am trying to use Hercules for the first time. After i installed mysql, downloaded Hercules and everything else i tried to compile the servers, but when i try to run then they open for about 2 seconds and then auto-close. It's hard to even take a snapshot, but here is what i got with some effort. I'm pretty sure i configured everything right in the database and conf files, so i don't have a clue to whats going on here. Some help would highly be appreciated