• 0
flpneo

Problem with No-IP

Question

When I use my ip wan in char.conf and map.conf files, I can connect and log in normally in the game.
But when change these two ip's wan by NO-IP, I get the message "failed to connect to server" before appearing characters.
Does anyone know how I can use NO-IP without being disconnected?
(Google translator, sorry)

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

Did you start the NO-IP aplication at your PC ?

Did you try use the name that you created in yout NO-IP account ?

Share this post


Link to post
Share on other sites
  • 0

Did you start the NO-IP aplication at your PC ?

Did you try use the name that you created in yout NO-IP account ?

My NO-IP is working normally used ping from a PC outside of my internal network and it worked, but neither manages to come put the password to login.

You say to use my e-mail account of the no-ip? I have not felt it, but did not work.

Share this post


Link to post
Share on other sites
  • 0

Not your e-mail, NO-IP let you use DDNS in your PC, for this, you need login into your NO-IP account creat a name, e.g: myroserver.biz.

 

After this, enter in NO-IP aplication on your PC, select the host in this example: myroserver.biz, and everyone who try acess myroserver.biz will be redirect yo your PC.

 

In client side part switch the IP to DDNS name(myroserver.biz) and try to connect.

 

3 Important things:

1-)Open your router/firewall/Windows ports, make a rule to everybody who try to acess your WAN IP in ragnarok ports be redirect to your PC.

 

2-)Make sure your internet provider doens't block reverse IP connections, when this is blocked you acess your PC by the Internet IP, in my contry have a company which provider of internet that block this.

 

3-)You've said 2 IPs ? You have a loadbalancer ?

Share this post


Link to post
Share on other sites
  • 0

Not your e-mail, NO-IP let you use DDNS in your PC, for this, you need login into your NO-IP account creat a name, e.g: myroserver.biz.

 

After this, enter in NO-IP aplication on your PC, select the host in this example: myroserver.biz, and everyone who try acess myroserver.biz will be redirect yo your PC.

 

In client side part switch the IP to DDNS name(myroserver.biz) and try to connect.

 

3 Important things:

1-)Open your router/firewall/Windows ports, make a rule to everybody who try to acess your WAN IP in ragnarok ports be redirect to your PC.

 

2-)Make sure your internet provider doens't block reverse IP connections, when this is blocked you acess your PC by the Internet IP, in my contry have a company which provider of internet that block this.

 

3-)You've said 2 IPs ? You have a loadbalancer ?

Regarding the firewall and ports, it's all right, as I said before with my WAN IP inserted in char.conf and map.conf files I can connect normally, only when I use my NO-IP that is not connecting (myroserver.biz) the two ip's that said are the two places that I insert my public IP in char.conf and map.conf files.

The application of NO-IP is properly installed and I am logged in to my account.

My NO-IP is working, I can answer when PING using any PC the internet.

But when I insert my NO-IP (myroserver.biz) in char.conf and map.conf files, I can not connect to my server.

Share this post


Link to post
Share on other sites
  • 0

 

Not your e-mail, NO-IP let you use DDNS in your PC, for this, you need login into your NO-IP account creat a name, e.g: myroserver.biz.

 

After this, enter in NO-IP aplication on your PC, select the host in this example: myroserver.biz, and everyone who try acess myroserver.biz will be redirect yo your PC.

 

In client side part switch the IP to DDNS name(myroserver.biz) and try to connect.

 

3 Important things:

1-)Open your router/firewall/Windows ports, make a rule to everybody who try to acess your WAN IP in ragnarok ports be redirect to your PC.

 

2-)Make sure your internet provider doens't block reverse IP connections, when this is blocked you acess your PC by the Internet IP, in my contry have a company which provider of internet that block this.

 

3-)You've said 2 IPs ? You have a loadbalancer ?

Regarding the firewall and ports, it's all right, as I said before with my WAN IP inserted in char.conf and map.conf files I can connect normally, only when I use my NO-IP that is not connecting (myroserver.biz) the two ip's that said are the two places that I insert my public IP in char.conf and map.conf files.

The application of NO-IP is properly installed and I am logged in to my account.

My NO-IP is working, I can answer when PING using any PC the internet.

But when I insert my NO-IP (myroserver.biz) in char.conf and map.conf files, I can not connect to my server.

Can you try another name ?

Edited by Felipe

Share this post


Link to post
Share on other sites
  • 0

 

 

Not your e-mail, NO-IP let you use DDNS in your PC, for this, you need login into your NO-IP account creat a name, e.g: myroserver.biz.

 

After this, enter in NO-IP aplication on your PC, select the host in this example: myroserver.biz, and everyone who try acess myroserver.biz will be redirect yo your PC.

 

In client side part switch the IP to DDNS name(myroserver.biz) and try to connect.

 

3 Important things:

1-)Open your router/firewall/Windows ports, make a rule to everybody who try to acess your WAN IP in ragnarok ports be redirect to your PC.

 

2-)Make sure your internet provider doens't block reverse IP connections, when this is blocked you acess your PC by the Internet IP, in my contry have a company which provider of internet that block this.

 

3-)You've said 2 IPs ? You have a loadbalancer ?

Regarding the firewall and ports, it's all right, as I said before with my WAN IP inserted in char.conf and map.conf files I can connect normally, only when I use my NO-IP that is not connecting (myroserver.biz) the two ip's that said are the two places that I insert my public IP in char.conf and map.conf files.

The application of NO-IP is properly installed and I am logged in to my account.

My NO-IP is working, I can answer when PING using any PC the internet.

But when I insert my NO-IP (myroserver.biz) in char.conf and map.conf files, I can not connect to my server.

Can you try another name ?

Yes, same problem ...

The strange thing is that the login server it connects, if I mistake the password message appears incorrect password.

But when I enter the correct password it fails to connect to char server.

Share this post


Link to post
Share on other sites
  • 0

 

 

 

Not your e-mail, NO-IP let you use DDNS in your PC, for this, you need login into your NO-IP account creat a name, e.g: myroserver.biz.

 

After this, enter in NO-IP aplication on your PC, select the host in this example: myroserver.biz, and everyone who try acess myroserver.biz will be redirect yo your PC.

 

In client side part switch the IP to DDNS name(myroserver.biz) and try to connect.

 

3 Important things:

1-)Open your router/firewall/Windows ports, make a rule to everybody who try to acess your WAN IP in ragnarok ports be redirect to your PC.

 

2-)Make sure your internet provider doens't block reverse IP connections, when this is blocked you acess your PC by the Internet IP, in my contry have a company which provider of internet that block this.

 

3-)You've said 2 IPs ? You have a loadbalancer ?

Regarding the firewall and ports, it's all right, as I said before with my WAN IP inserted in char.conf and map.conf files I can connect normally, only when I use my NO-IP that is not connecting (myroserver.biz) the two ip's that said are the two places that I insert my public IP in char.conf and map.conf files.

The application of NO-IP is properly installed and I am logged in to my account.

My NO-IP is working, I can answer when PING using any PC the internet.

But when I insert my NO-IP (myroserver.biz) in char.conf and map.conf files, I can not connect to my server.

Can you try another name ?

Yes, same problem ...

The strange thing is that the login server it connects, if I mistake the password message appears incorrect password.

But when I enter the correct password it fails to connect to char server.

Mind showing the configuration files (char-server.conf and map-server.conf)

Share this post


Link to post
Share on other sites
  • 0

 

 

 

 

Not your e-mail, NO-IP let you use DDNS in your PC, for this, you need login into your NO-IP account creat a name, e.g: myroserver.biz.

 

After this, enter in NO-IP aplication on your PC, select the host in this example: myroserver.biz, and everyone who try acess myroserver.biz will be redirect yo your PC.

 

In client side part switch the IP to DDNS name(myroserver.biz) and try to connect.

 

3 Important things:

1-)Open your router/firewall/Windows ports, make a rule to everybody who try to acess your WAN IP in ragnarok ports be redirect to your PC.

 

2-)Make sure your internet provider doens't block reverse IP connections, when this is blocked you acess your PC by the Internet IP, in my contry have a company which provider of internet that block this.

 

3-)You've said 2 IPs ? You have a loadbalancer ?

Regarding the firewall and ports, it's all right, as I said before with my WAN IP inserted in char.conf and map.conf files I can connect normally, only when I use my NO-IP that is not connecting (myroserver.biz) the two ip's that said are the two places that I insert my public IP in char.conf and map.conf files.

The application of NO-IP is properly installed and I am logged in to my account.

My NO-IP is working, I can answer when PING using any PC the internet.

But when I insert my NO-IP (myroserver.biz) in char.conf and map.conf files, I can not connect to my server.

Can you try another name ?

Yes, same problem ...

The strange thing is that the login server it connects, if I mistake the password message appears incorrect password.

But when I enter the correct password it fails to connect to char server.

Mind showing the configuration files (char-server.conf and map-server.conf)

Are the standard files.

I am using the import folder.

 

char_conf.txt:

login_ip: 192.168.2.7//my LAN

char_ip: myroserver.biz//my public ip

 

map_conf.txt:

char_ip: 192.168.2.7//my LAN

map_ip: myroserver.biz//my public ip

Share this post


Link to post
Share on other sites
  • 0

char_conf.txt:
login_ip: 127.0.0.1
char_ip: myroserver.biz

map_conf.txt:
char_ip: 127.0.0.1

map_ip: myroserver.biz

 

Try this

Share this post


Link to post
Share on other sites
  • 0

char_conf.txt:

login_ip: 127.0.0.1

char_ip: myroserver.biz

 

map_conf.txt:

char_ip: 127.0.0.1

map_ip: myroserver.biz

 

Try this

I've tried without success

I did another test.

 

char_conf.txt:

login_ip: 127.0.0.1

char_ip: 200.138.0.202////my public ip wan

 

map_conf.txt:

char_ip: 127.0.0.1

map_ip: myroserver.biz//my public ip

 

In this way the screen appears to select character.

But then, after choosing the character before you see the map, I am disconnected.

Share this post


Link to post
Share on other sites
  • 0

 

char_conf.txt:

login_ip: 127.0.0.1

char_ip: myroserver.biz

 

map_conf.txt:

char_ip: 127.0.0.1

map_ip: myroserver.biz

 

Try this

I've tried without success

I did another test.

 

char_conf.txt:

login_ip: 127.0.0.1

char_ip: 200.138.0.202////my public ip wan

 

map_conf.txt:

char_ip: 127.0.0.1

map_ip: myroserver.biz//my public ip

 

In this way the screen appears to select character.

But then, after choosing the character before you see the map, I am disconnected.

It's look like you have a DNS resolution problem, trying to open port 53 UDP(DNS) in your router.

If didn't work try to open port 53 TCP too.

 

You can make a DMZ to your computer too.

Share this post


Link to post
Share on other sites
  • 0

 

 

char_conf.txt:

login_ip: 127.0.0.1

char_ip: myroserver.biz

 

map_conf.txt:

char_ip: 127.0.0.1

map_ip: myroserver.biz

 

Try this

I've tried without success

I did another test.

 

char_conf.txt:

login_ip: 127.0.0.1

char_ip: 200.138.0.202////my public ip wan

 

map_conf.txt:

char_ip: 127.0.0.1

map_ip: myroserver.biz//my public ip

 

In this way the screen appears to select character.

But then, after choosing the character before you see the map, I am disconnected.

It's look like you have a DNS resolution problem, trying to open port 53 UDP(DNS) in your router.

If didn't work try to open port 53 TCP too.

 

You can make a DMZ to your computer too.

I tried this, I did DMZ and not solved the problem.

I do not know if it's DNS, because in clientinfo.xml is my NO-IP and is showing my server to connect.

Share this post


Link to post
Share on other sites
  • 0

Why in char_conf, there's ip? But in map_conf, there's no-ip domain?

Shouldn't they be same(considering you are hosting under same machine)

Share this post


Link to post
Share on other sites
  • 0

Why in char_conf, there's ip? But in map_conf, there's no-ip domain?

Shouldn't they be same(considering you are hosting under same machine)

 
 
In fact they are the same IP's, but map_conf is with the NO-IP domain to test.

Should succeed in this configuration because they are the same IP's.

NO-IP translates my IP WAN to NO-IP domain.

It's all hosted on the same machine.

Should work out with both my IP WAN map_conf and char_conf, as my NO-IP map_conf and char_conf.

 

But ... when I insert the NO-IP domain, it does not work.

only works with IP WAN ....

I need the NO-IP domain because my IP WAN is not fixed.

Imagine I have to change my IP in all the time he files that change ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now