Jump to content


Photo

[Guide] Create your server & Client (2016/08)

create server newbie client

  • Please log in to reply
36 replies to this topic

#21 devilz33

devilz33

    Member

  • Members
  • PipPip
  • 29 posts

Posted 02 October 2016 - 10:27 AM

hello, can i get a help. i add custom items in my created server using this guide but it does not appear when equipped



#22 ZelosAvalon

ZelosAvalon

    Advanced Member

  • Members
  • PipPipPip
  • 219 posts
  • Emulator:Hercules

Posted 04 October 2016 - 07:35 PM

the best kRO Client Donwload Link, just for help: https://www.nickyzai.com/?p=kro


Zelos_logo.png


#23 mrlongshen

mrlongshen

    Noobies

  • Members
  • PipPipPip
  • 1127 posts
  • Locationlocalhost 127.0.0.1
  • Emulator:Hercules

Posted 04 October 2016 - 11:41 PM

i

 

the best kRO Client Donwload Link, just for help: https://www.nickyzai.com/?p=kro

 

its not up to dated


Long live Hercules emulator


#24 AkQ

AkQ

    Member

  • Members
  • PipPip
  • 14 posts

Posted 06 October 2016 - 01:51 PM

Great guide!

 

But do you think that new-to-linux-world should be installing insecure server like this?
Meaning, anyone who needs this guide is probably unaware of security things. I know that it's not really part of the guide, but it really should be mentioned for the sake of all the new servers who are insecure :S
At least give a link to things to do first for a brand new Debian server before starting to follow the guide.
Anyway, great guide! :)



#25 Monsieur Panda

Monsieur Panda

    Advanced Member

  • Members
  • PipPipPip
  • 90 posts
  • LocationTokyo
  • Emulator:Hercules

Posted 06 October 2016 - 02:36 PM

Imo, people who doesn't know basic, or at least, cannot even do basic search, should not open a server. But right, next guide will have a section "to go further" explaining security and other :)



#26 AkQ

AkQ

    Member

  • Members
  • PipPip
  • 14 posts

Posted 06 October 2016 - 03:18 PM

Imo, people who doesn't know basic, or at least, cannot even do basic search, should not open a server. But right, next guide will have a section "to go further" explaining security and other :)

I could not agree more. But your guide makes it possible to host server without almost any knowledge at all. At that point, "should" and "should not" -things don't really matter.

If you need help with next guide, i'm up. I was actually thinking to make a Debian guide myself, with exception of using two servers, one for emulator and one for web-server. But i never seem to have time to do it.



#27 Monsieur Panda

Monsieur Panda

    Advanced Member

  • Members
  • PipPipPip
  • 90 posts
  • LocationTokyo
  • Emulator:Hercules

Posted 06 October 2016 - 04:08 PM

Got it, I'll come to you when I will start it !



#28 Luffy

Luffy

    Advanced Member

  • Members
  • PipPipPip
  • 282 posts
  • Location#DDos
  • Emulator:Hercules

Posted 07 October 2016 - 08:09 AM

a guide too for Windows User :D


AnnieRuru Fan™
Angelmelody Fan™

2ro0olu.jpg
Don't forget to click rep_up.png if i helped you!
 


#29 Hafflex

Hafflex

    Advanced Member

  • Members
  • PipPipPip
  • 66 posts

Posted 10 October 2016 - 12:22 AM

Thanks for this guide, helps a lot of newbies.


I'm willing to learn, please be patient and I'll do my best to catch up!

hafflexsig_zpsiwfaodsg.gif


#30 AkQ

AkQ

    Member

  • Members
  • PipPip
  • 14 posts

Posted 11 October 2016 - 04:05 PM

This should be sticky, and add to the topic title: "Debian/Ubuntu"



#31 roking

roking

    Newbie

  • Members
  • Pip
  • 4 posts
  • Github:keiji91

Posted 17 November 2016 - 05:31 PM

im facing problems, my char and map server starts just fine, but whenever i start the login server, it will await connection to char server, once done the login server will crash. 



#32 Valterri

Valterri

    Newbie

  • Members
  • Pip
  • 2 posts
  • Github:Valterri

Posted 23 November 2016 - 01:08 PM

Great Tutorial..thnx man.

 

But...appear this error for me

 

clif_parse: Received unsupported packet (packet 0x49f0 (0x49f0), 13 bytes received), disconnecting session #7.

 

anybody know how i resolve this??



#33 kanemi

kanemi

    Member

  • Members
  • PipPip
  • 10 posts

Posted 27 November 2016 - 11:35 AM

Edit: Nothing, sorry.


Edited by kanemi, 27 November 2016 - 05:41 PM.


#34 n0tm3

n0tm3

    Member

  • Members
  • PipPip
  • 14 posts
  • LocationPhilippines
  • Emulator:Hercules

Posted 29 November 2016 - 11:00 PM

I followed your instructions, but I am stuck. after selecting server, it wont continue to the character selection screen. it will only say failed to connect to server. whenever I look at the console of the herc emulator, there is no error. can you help me please? :D



#35 larva

larva

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 01 December 2016 - 05:56 PM

Hello, im trying to setup the server but the compile gives me a error of mysql.


checking for mysql_config... no
checking for mysql_init... no
checking mysql.h usability... no
checking mysql.h presence... no
checking for mysql.h... no
checking MySQL library (required)... no
configure: error: MySQL not found or incompatible
 

Server OS. OpenSuse 42.1 x64

Mysql version:

> mysql -V
mysql  Ver 15.1 Distrib 10.0.25-MariaDB, for Linux (x86_64) using readline 5.1
 

any help would be appreciated.

Opensuse is not so diferent than CentOS i assume it should work?

 

 

EDIT:  i know whats the problem.... the problem is that i moved mysql to another location (hard drive space issues)..  tested the ./configure in a clean setup and compiled with out problems.

now the real question is. how can i tell the ./configure where is the new location of mysql ?

thanks.


Edited by larva, 01 December 2016 - 06:26 PM.


#36 Tristan

Tristan

    Member

  • Members
  • PipPip
  • 15 posts
  • Github:tristan

Posted 16 February 2017 - 02:40 AM

only +9 reputation including mine oh come on guys this guy needs more than that! :D 



#37 Rockstar xD

Rockstar xD

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 February 2017 - 02:17 PM

I've tried to compile the emulator using Visual Studio 2017 RC and it returned me the following error:

 

C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.Cpp.Platform.targets(57,5): error MSB8020: The build tools for v140 (Platform Toolset = 'v140') cannot be found. To build using the v140 build tools, please install v140 build tools.  Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Retarget solution".
4>Done building project "map-server.vcxproj"
 

Anybody knows how to fix it? I have 8 errors at end of compilations attempts.

 

@EDIT

I'm sorry! I posted this too early, guys.
I followed the web instructions and I installed the tools, retargeted the solutions and it worked! (at my second attempt to do this! finally works!)


Edited by Rockstar xD, 16 February 2017 - 02:27 PM.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


This topic has been visited by 397 user(s)