Rytech

2016-12-28aRagexeRE Client

18 posts in this topic

File Name: 2016-12-28aRagexeRE Client
File Submitter: Rytech
File Submitted: 27 Jan 2017
File Category: Client Resources

Release for the 2016-12-28aRagexeRE client.

Be sure to set your DATA.INI to read rdata.grf first and data.grf 2nd.

Click here to download this file


After seeing the success of the unpacking of the last 2 clients I felt its time to finally get a new one out. A very new one to help drive things in motion again. So here's a late xmas president to everyone. Packet lengths, shuffles, and encryption keys are provided in the text file.

 

Big thanks to Nova for helping with the testing of the client and the connection fixes and giving me the motivation to make this possible.

 

1. Due to a big change in how regular client are being packed by Gravity, its not possible to do a stable unpacking of them. Only RE clients can be done without issues. So please don't ask for regular ones.

 

2. Because RE clients are sakray test clients, im only doing releases that I feel are stable and will only make them as needed. So maybe one or 2 clients will be released a year.

 

3. As with all newly released clients itl take time to get them fully supported. This is a very new client and will have some issues at the start. Its stable but do expect some things to not work right away. DO NOT PM ME OR ANY OTHER DEV'S ON HOW TO GET IT TO WORK!!!! Your PM's will be ignored.

 

4. Currently as of this time, the client will not work with Hercules or rAthena even if you add the shuffles and encryption keys. Ive tested and gotten this to work on 3CeAM and a friend's test server that uses rAthena with a small fix. ill provide info on how to fix this. You can apply it yourself or wait for dev's to add it.

 

Other Info: Here's what to expect so far....

 

Nemo

Msgstringtable.txt and exe's english translation patches do not work. Its not possible to extract the latest msgstringtable ether. Also got word that the hair style patch also fails. Don't know what else fails but do expect a number of patches to not work or cause issues. If you find any other patches that fails, report them in the Nemo Patcher topic.

 

Hercules / rAthena

The client's login and character select will function. But after selecting a character, the client will sit for a moment and then time out. This is because Gravity is no longer using the ZC_ACCEPT_ENTER3 packet and went back to using the older ZC_ACCEPT_ENTER2. So you have to edit the source to have it use the 2nd version of ACCEPT_ENTER or else the timeout issue will happen. Im not going into tech details on how to apply the change. Thats for you to do or just wait for someone to do it.

 

Client

Be sure to have your client's data.grf and rdata.grf patched to 2016-12-28 or newer to support the client. Being behind this date could result in client file errors and/or crashes. Do I even need to say this? :P

 

If anyone has any questions, ask here. Again, DO NOT PM ME OR OTHER DEV'S FOR HELP!!!!! ASK HERE FOR HELP AND INFO!!!!!

Share this post


Link to post
Share on other sites

It seems that someone is annoyed with so many PMs, anyway, good job again Ryech.

It should take a lot of patience to look for a client near 2017 who is stable.

Edited by ShadowChaser

Share this post


Link to post
Share on other sites

Good news. Ide As came up with a temp solution to resolving the issues with the 2 recommended patches that fail with Nemo.

 

1. For the Translate Client patch you can do the following....
Ide As: You said that NEMO's translate client patch fails. Actually you can fix that by removing Taekwon patch line in TranslateClient.qs

 

2. As for the read msgstringstable.txt, its possible to set your clientinfo.xml file to a langtype that will make it read the text string table. Its works with 1 (US) for sure and I think itl work with a number of others. Not bothering to test which ones tho.

 

Also its been found that a few item packets will need updating. Seems the newest one used for adding items into inventory is 3 bytes bigger. Also vending is broken and will not properly show the items for sale to anyone viewing.

Share this post


Link to post
Share on other sites

Nice! Thanks Rytech :D. But the saddest part is NEMOs last commit was May 29, 2016 so even you posted some issues on github it will be a looooong way to go before it resolves some issues.

Edited by Lelouch

Share this post


Link to post
Share on other sites

Hello, I've been using 2012 client for very long time and thinking about using newer client, 
is this the most Stable and Latest client? or what is the most Stable + newest client? Thanks

Share this post


Link to post
Share on other sites

if you need a working mail system I'd use 2014-10-22bRagexe.

 

but if you don't need a mail system, you could also use a 2015 ragexe, don't know which is most stable ^^

Share this post


Link to post
Share on other sites

Hello, I've been using 2012 client for very long time and thinking about using newer client, 

is this the most Stable and Latest client? or what is the most Stable + newest client? Thanks

perhaps the most stable client with support for dresspack i think is client ver 2015-10-29aRagexeRE.. not too old.. but, not too new.. not too new i mean already supported by the emulator (mine using 3CeAM, not sure about other emulator, but pretty sure herc do support this client ver) & nemo patcher seems able to patch this client. while not old is most interesting feature such as dresspack, doram.. already supported by the emulator...

Edited by hazimjauhari90

Share this post


Link to post
Share on other sites

wow impresionante! 

 

Cool!  :D  ty Rytech 

Share this post


Link to post
Share on other sites

Good news. Ide As came up with a temp solution to resolving the issues with the 2 recommended patches that fail with Nemo.

 

1. For the Translate Client patch you can do the following....

Ide As: You said that NEMO's translate client patch fails. Actually you can fix that by removing Taekwon patch line in TranslateClient.qs

 

2. As for the read msgstringstable.txt, its possible to set your clientinfo.xml file to a langtype that will make it read the text string table. Its works with 1 (US) for sure and I think itl work with a number of others. Not bothering to test which ones tho.

 

Also its been found that a few item packets will need updating. Seems the newest one used for adding items into inventory is 3 bytes bigger. Also vending is broken and will not properly show the items for sale to anyone viewing.

Ryan congratulations for the hexed! Maybe you can create a little diff to fix the issue with vending? Thanks!

Share this post


Link to post
Share on other sites

The vending issue is a packet related problem. There's a few new item packets that needs to be coded in to fix it but I don't know the structures.

Share this post


Link to post
Share on other sites

If there's no way nemo can work with these certain patches, is there an alternative way to do the patching using a different tool or something and maybe some few tuts?

Share this post


Link to post
Share on other sites

Hi All,

 

Tried to login with this client (2016-12-28a) and I received this error message "Your game exe is not the latest version(5)".

 

I did change the packet version inside the mmo.h file and re-compile it. I even search the forum and google yet I can't found any answer for this issue. Please help. Thanks

Share this post


Link to post
Share on other sites

Is this client even yet supported by hercules? ^^

Share this post


Link to post
Share on other sites

2016-12-28 is not. because issue with client after unpacking. But support many other 2016 clients. For 2017 clients pull request still not merged, but working

Share this post


Link to post
Share on other sites

2016-12-28 is not. because issue with client after unpacking. But support many other 2016 clients. For 2017 clients pull request still not merged, but working

 

Meaning client dated 2016-12-28a not supported by hercules yet? I even tried the 2016-02-03a & 2015-10-29a, both also having the same issue as the above.

 

Error message: "Your game exe is not the latest version(5)"

 

Can anyone else help me on this issue? Thanks in advance

Share this post


Link to post
Share on other sites

 

2016-12-28 is not. because issue with client after unpacking. But support many other 2016 clients. For 2017 clients pull request still not merged, but working

 

Meaning client dated 2016-12-28a not supported by hercules yet? I even tried the 2016-02-03a & 2015-10-29a, both also having the same issue as the above.

 

Error message: "Your game exe is not the latest version(5)"

 

Can anyone else help me on this issue? Thanks in advance

I guess that's something with hash check.

You might have enabled hash checking, disable it and try.

Share this post


Link to post
Share on other sites

 

2016-12-28 is not. because issue with client after unpacking. But support many other 2016 clients. For 2017 clients pull request still not merged, but working

 

Meaning client dated 2016-12-28a not supported by hercules yet? I even tried the 2016-02-03a & 2015-10-29a, both also having the same issue as the above.

 

Error message: "Your game exe is not the latest version(5)"

 

Can anyone else help me on this issue? Thanks in advance

2016-02-03 supported, but 2015-10-29 is not

See in src/map/packets.h

Search date what you need and see is comment "shuffle packets" present and after some pakets. If it present, then this version supported.

Share this post


Link to post
Share on other sites

 

 

2016-12-28 is not. because issue with client after unpacking. But support many other 2016 clients. For 2017 clients pull request still not merged, but working

 

Meaning client dated 2016-12-28a not supported by hercules yet? I even tried the 2016-02-03a & 2015-10-29a, both also having the same issue as the above.

 

Error message: "Your game exe is not the latest version(5)"

 

Can anyone else help me on this issue? Thanks in advance

I guess that's something with hash check.

You might have enabled hash checking, disable it and try.

This help the game exe issue, however tried to login and disconnected from server

 

Error:

"[Warning]: clif_parse: Received unsupported packet (packet 0x44c5 (0x4a37), 19 bytes received), disconnecting session #3."

 

Don't understand even I search around the forum. Any guideline for this message?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now