• 0
THPO

2014-10-22 Issues with latest version of Hercules

Question

Posted (edited)

Hi Guys, I have been trying to work with the latest version or Herc and now I decided to use the default client currently being supported.

which is 2014-10-22 I got the Unpatched and Diffed it with NEMO mostly with recommened options.

Spoiler

5 Enable Proxy Support
9 Disable 1rag1 type parameters (Recommended)
10 Disable 4 Letter Character Name Limit
11 Disable 4 Letter User Name Limit
12 Disable 4 Letter Password Limit
13 Disable Ragexe Filename Check (Recommended)
15 Disable HShield (Recommended)
19 Enable Title Bar Menu
23 Enable /who command (Recommended)
24 Fix Camera Angles (Recommended)
33 Always Call SelectKoreaClientInfo() (Recommended)
34 Enable /showname (Recommended)
35 Read Data Folder First
36 Read msgstringtable.txt (Recommended)
37 Read questid2display.txt (Recommended)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
40 Restore Login Window (Recommended)
41 Disable Nagle Algorithm (Recommended)
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
47 Use Ragnarok Icon
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
53 Use Ascii on All LangTypes (Recommended)
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
73 Remove Hourly Announce (Recommended)
75 Enable Flag Emoticons
84 Remove Serial Display (Recommended)
90 Enable DNS Support (Recommended)
96 Remove GM Sprites
97 Cancel to Login Window (Recommended)
209 Enable Mail Box for All LangTypes
213 Disable Help Message on Login (Recommended)
 

It went in Ok with no issues on the Server being reported but somehow I've noticed this odd stuffs:

1. NPC's are missing but when I try to use @refresh or @warp they will pop-up.

2. ALT-Q and Inventory Items & Equips are missing but using @itemlist it will tell you it's in the inventory.

59CN0nG.png

 

3. Movespeed is so fast and sometimes you can't move can be fixed by warping or using @refresh

So, I think this is issue is from a missing packet that stops the client from working normally.

because I tried the Client with rAthena latest version it works fine, but somehow with Hercules it works odd/abnormal.

 

 

 

Edited by THPO

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Posted (edited)

Should be fixed with last commit (a couple hours ago)

Edit: At least part of it, I didn't notice other problems

Edited by KirieZ

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

That is nice Thanks :D

 

It's Fixed :D

Edited by THPO

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now