• 0
Sign in to follow this  
Followers 0
Katsura

ligando emulador

Question

Boa noite!

Estou começando agora a mexer com o emulador e sou totalmente newbie no assunto.

Paguei um host da virtuaTI e usei o emulador de lá mesmo (Hercules no caso).

Já compilei e tudo, mas está dando um erro de root que não sei como resolver (Acho que é simples, mas não consigo T-T)

Segue o erro:

[Info]: Hercules 64-bit for Linux
[Info]: Exported revision (src): ''
[Info]: Exported revision (scripts): 'Unknown'
[Info]: OS version: 'CentOS release 6.9 (Final) [x86_64]'
[Info]: CPU: 'Intel(R) Xeon(R) CPU X3440 @ 2.53GHz [8]'
[Info]: Compiled with GCC v4.4.7
[Info]: Compile Flags: -g -O2 -pipe -ffast-math -Wall -Wextra -Wno-sign-compare -std=c99 -Wno-unused-parameter -Wno-clobbered -Wempty-body -Winit-self -Wpointer-arith -Wformat-security -Wformat -Wformat-y2k -Wundef -Wnested-externs -Wold-style-definition -Woverlength-strings -Wredundant-decls -Wcast-qual -Wno-format-nonliteral -Wno-switch -Wno-missing-field-initializers -fno-strict-aliasing -g -fno-omit-frame-pointer -DHAVE_EXECINFO -DMAXCONN=16384 -I../common -DHAS_TLS -DHAVE_SETRLIMIT -DHAVE_STRNLEN -DDEBUG -DHAVE_MONOTONIC_CLOCK
[Info]: Timer Function Type: monotonic clock
[Fatal Error]: You are running Hercules with root privileges, it is not necessary, nor recommended. Aborting.

Obrigado a quem ajudar ^^'

@edit

Isso ocorre com o char-server, loguin-server e map-server.

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

Posted (edited)

Adicione permissão 777 ao arquivo sysinfogen.sh.

Em seguida vá ao seu banco de dados e cheque se adicionou tudo certo as tabelas, lembrando que as tabelas logs e main.sql

nos emuladores do hercules vc upa as 2 tabelas no mesmo banco de dados no caso o seulogindocpainel_ragnarok.

Também aconselho você abrir ticket de suporte que o Carlos Lain responde rápido...

mais uma coisa você utiliza o rlcp ?? se  sim ela mostra os erros com mais detalhes mais no seu caso é privilegios provavelmente seja os privilegios do seu banco de dados phpmyadmin

 

Haaa sim esse erro não influencia em nada, é mais um avizo de que seus arquivos estão com alguns privilegios liberados que não tem necessidade...

pode utilizar normalmente que não vai ter erro algum kkk 

é nois !!!

Edited by Yazoo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0