• 0
Sign in to follow this  
Followers 0
Baps

Error with my client

Question

Hello everyone,

Sorry for this post , it's not very original but i'm stuck... I try to implement a server on a Virtual Machien to do some tests (scripts, security, etc...), my server start normally (no errors apparently) with the good configuration in the conf/char/char-server.conf, conf/map/map-server.conf and conf/global/sql_connection.conf because i'm only on local for test so I try to connect from 192.168.1.10 (my physical pc) to 192.168.1.100 (server in virtual machine).

The problem is when i try to connect with my client, I enter my login, I see my server but just after selected it and just before the char page comes, I take a "Failed to connect to server". On my server, I have no errors, the server accepted my connection but close it just after.

My server run on Debian 8 Jessie, but i think my problem comes from my client, something is wrong with it but I don't know what. I try many RageXE, stable or not but I have the same problem.

Maybe you have some idea for me or a good guide to make a recent client ?

Thanks

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Hello! You should try applying patch "Enable Proxy Support". In this case EXE will use IP from "clientinfo.xml" for all servers(login, char, map).

Share this post


Link to post
Share on other sites
  • 0

Oh okay thank you, i'm at work for now but i'll test it when i come home. Which RageXE do you suggest for the client (I'm not using renewal) ?

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0