4144

Another Nemo patcher fork

145 posts in this topic

In drawing code i see only layers limit to 7 one of them is head.

probably head sprites limit somewhere else.

Share this post


Link to post
Share on other sites
4 hours ago, M45T3R said:

I found out client is cutting the head frames somehow.. to something between 7~9 why? Because I added 14 extra frames to a hairstyle and it only rendered like 7~9 of them, then after that the head just dissapears I knew because I fliped the head halfway just to know if I was applyng my changes.. 

4

I modified "imf" file for Ranger and added it to GRF.

30 frames of hairstyle work now. You can check it. Use female Ranger and @hairstyle 2

https://mega.nz/#!gY1VzQpb!cFnkDdulSGUt9mvJ-Dw61m8vHeSSat5xUpPyjr01vqM

-------------

P.S.

It is a bad idea to use 30 frames for body and 8 for head. The position of the head is different according to the frame number.

If you use a different amount of frames for body and head - you will get "random" position of head relative to the body.

It will be out of sync:

Head frames: [00][01][02][03][04][05][06][07][00][01][02][03][04][05][06][07]....
Body frames: [00][01][02][03][04][05][06][07][08][09][10][11][12][13][14][15]....

Edited by Functor

Share this post


Link to post
Share on other sites
11 hours ago, Functor said:

I modified "imf" file for Ranger and added it to GRF.

30 frames of hairstyle work now. You can check it. Use female Ranger and @hairstyle 2

https://mega.nz/#!gY1VzQpb!cFnkDdulSGUt9mvJ-Dw61m8vHeSSat5xUpPyjr01vqM

-------------

P.S.

It is a bad idea to use 30 frames for body and 8 for head. The position of the head is different according to the frame number.

If you use a different amount of frames for body and head - you will get "random" position of head relative to the body.

It will be out of sync:

Head frames: [00][01][02][03][04][05][06][07][00][01][02][03][04][05][06][07]....
Body frames: [00][01][02][03][04][05][06][07][08][09][10][11][12][13][14][15]....

Wait this is amazing, I understod what you did with the .IMF file but how did you edit it tho? Without decrypting? It looks all gibberish after I open it 

rSgonE6.png

So I need to re-make all the headgears ?

And any idea on why the animation speed is fixed on 2018 clients? It obeys that settings on 2015 10 30 but the animation looks slow-mo in 2018 06 20

Could this have something to do with: 

(00) Priority 0  

Params?

 

@4144

11 hours ago, 4144 said:

In drawing code i see only layers limit to 7 one of them is head.

probably head sprites limit somewhere else.

Do you see anything on animation speed? I think thats the only problem now, the animation speed on 2015 10 30 shows like this: VKjUReZ.gif 30 fps at 30MS speed

but on 2018 06 20 it looks like this: g40hHMA.gif like if it was extending the animation speed to 100+MS

2015 client Its apparently following this 2b01F6r.png setting on the .ACT but 2018 is not even if I put 2000ms it doesnt follow that rule but 2015 does

Tokei's ACT Editor and Actor2 have that setting and 2015 clients follow it but 2018 doesnt seem to

Share this post


Link to post
Share on other sites
9 hours ago, M45T3R said:

Wait this is amazing, I understod what you did with the .IMF file but how did you edit it tho? Without decrypting? It looks all gibberish after I open it 

rSgonE6.png

There is no sense to open "imf" file with "Notepad". Because it is binary data. I modified it manually by using Hex editor.

 

9 hours ago, M45T3R said:

So I need to re-make all the headgears ?

Yes. But it is better to create tool for automation.

 

9 hours ago, M45T3R said:

And any idea on why the animation speed is fixed on 2018 clients? It obeys that settings on 2015 10 30 but the animation looks slow-mo in 2018 06 20

Could this have something to do with: 

(00) Priority 0  

Params?

I don't have spare time to check it in debugger right now. I will inform you once I have info about it.

You should upload your EXE to the file hosting and post a link.

Edited by Functor

Share this post


Link to post
Share on other sites
4 hours ago, Functor said:

There is no sense to open "imf" file with "Notepad". Because it is binary data. I modified it manually by using Hex editor.

 

Yes. But it is better to create tool for automation.

 

I don't have spare time to check it in debugger right now. I will inform you once I have info about it.

ACT Editor from Tokei's has automation scripts but I don't know C#.. thats the language scripts are supposed to be made in 

Also here is the unpatched .EXE

https://www.mediafire.com/file/c8q10uqxq375hfe

 

 

This one is patched if you don't want to patch the file above: https://www.mediafire.com/file/dren7r7pleefl41

Share this post


Link to post
Share on other sites
8 hours ago, Functor said:

@M45T3R

I fixed unpatched EXE. So, you have to apply patches and test it.

https://mega.nz/#!YI1zEQCL!oLaji6Toi541B2gi5VwRyFG3uN7Co-JZWP0T4Zi6Ilo

It does work.. it would be nice to make a patch for this because its a bug with newer clients but yeah now everything is fixed and we solved the Head problem.. now its just to remake all the headgears .ACT uhm... I wish understod C#

 

Many thanks @Functor !

Share this post


Link to post
Share on other sites

Added to nemo some patches from other nemo fork. See changelog.

 

Also now clients not protected by themida can be downloaded now from nemo site: http://nemo.herc.ws/downloads/

Clients can be downloaded from different kro mirrors and not stored on server where site located.

Share this post


Link to post
Share on other sites

New patch "Change guild exp limit"

Share this post


Link to post
Share on other sites
On 29/10/2018 at 3:23 PM, 4144 said:

New patch "Change guild exp limit"

4144 can you reproduce that patch that Functor Applied to the .EXE file I gave him?

Share this post


Link to post
Share on other sites

may be. but i not sure is this is good idea. probably better ask him share patch bytes or nemo script?

 

Share this post


Link to post
Share on other sites
6 minutes ago, 4144 said:

may be. but i not sure is this is good idea. probably better ask him share patch bytes or nemo script?

 

@Functor could you share them please?

Share this post


Link to post
Share on other sites
On 15.11.2018 at 3:58 AM, M45T3R said:

@Functor could you share them please?

I think that this patch isn't useful enough for other admins to add it to NEMO. Because it fixes the problem in case "abnormal" amount of frames only. Default "act" files work fine even without this patch, don't they? ;-)

If you want to apply this patch, you should search bytes by using any HEX editor:

F3 0F 10 45 08 0F 57 C9 0F 2F C8 F3 0F 11 45 08 72 18 57

and change 72 18 to 90 90

The result should be like this:

F3 0F 10 45 08 0F 57 C9 0F 2F C8 F3 0F 11 45 08 90 90 57

 

Edited by Functor

Share this post


Link to post
Share on other sites
10 minutes ago, Functor said:

I think that this patch isn't useful enough for other admins to add it to NEMO. Because it fixes the problem in case "abnormal" amount of frames only. Default "act" files work fine even without this patch, don't they? ;-)

If you want to apply this patch, you should search bytes by using any HEX editor:

F3 0F 10 45 08 0F 57 C9 0F 2F C8 F3 0F 11 45 08 72 18 57

and change 72 18 to 90 90

The result should be like this:

F3 0F 10 45 08 0F 57 C9 0F 2F C8 F3 0F 11 45 08 90 90 57

 

Not on all clients actually this is a recurring problem on clients 2016 and higher I think

Share this post


Link to post
Share on other sites

I understand that not all EXE versions need this patch. But it doesn't change the fact, that patch is useless for admins which don't use "act" files with 30 frames for animation.

Share this post


Link to post
Share on other sites

@4144 Yes, let it be. You should add info to the description, that it helps in the case using act files with the big amount of frames. Thanks ;-)

New EXE versions don't use delay values from "act" file. They take/generate it by using another method. I didn't have time to analyze it more attentively. My patch forces EXE to use delay from "act" file, like it was with older EXE versions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now