• 0
Sav4Ge

bonus2
[Warning] pc_bonus2: unknown type 2061 16 15!

Question

Posted (edited)

Hello guys, 
I am facing a lil' problem on the source (I guess) and didn't find a way to solve. So I decided to come straight to the experts.
Please excuse my english, I've never put my footprint into a english school so let me know if something gets misunderstood.

My problem is that when I equip any item that uses bonus2  (i.e.g: <" bonus2 bSubRace, RC_ALL, 20; ">) the script doesn't work and I get this Warning on the map-server:

"[Warning]: pc_bonus2: unknown type 2061 16 15!
[ERROR] --- failed assertion ---
[Error] --- 'path to the file \src\map\pc.c:3849: '0' in function 'unknown'

[Error] --- end failed assertion --- "

#edit Feather Beret (5170 or 18755) uses bonus2 and the 10% damage reduction is an good example.

On the spoiler goes a print of the map-server warning:

Spoiler

https://prnt.sc/j4cnwe // I could not use the "Insert other media" button, idk why didn't work.

 

 

Other informations: 
My hercules is the latest get on the git;
Hexed: 2017 - 06 - 14
bonus and bonus3 are working fine.

Thanks for your time!
Sav4Ge. <3

Edited by Sav4Ge

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Posted (edited)

That happens to me sometimes and the problem is there are bonuses inserted in my custom items that are not available or different in hercules.

Edited by Rebel

Share this post


Link to post
Share on other sites
  • 0

2061 = SP_RACE_TOLERANCE
check you are using right db as this bonus only work in renewal if i recall

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

2 hours ago, Myriad said:

2061 = SP_RACE_TOLERANCE
check you are using right db as this bonus only work in renewal if i recall

Hey @Myriad,
Thanks for replying,


Thats it! Actually I was using AddRaceTolerance, it was my mistake. Damage Reduction are all working now that I've translated them into "bSubRace". By the way, there is still one problem:

<" bonus2 bAddRace,RC_All,20; "> Script for Turtle General's Card is not working but returns no error on map-server. I've made damage tests and the script is not working. I've managed to <" bonus bAtkRate,20; "> and is working fine just like Turtle General's should be. But the problem with <" bonus2 bAddRace,r,n "> comes into Hydra Card with script <" bonus2 bAddRace,RC_DemiPlayer,20; "> and the "not working bonus2 bAddRace problem" is going on all over the items that use it.

 

Any ideas about what should I do to solve <" bonus2 bAddRace,r,n; "> problems?
Thanks A LOT for your time,
Sav4Ge <3

Edited by Sav4Ge
Tagging Myriad

Share this post


Link to post
Share on other sites
  • 0

bonus2(bAddRace, RC_DemiPlayer, 20);

works fine for me

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, Myriad said:

bonus2(bAddRace, RC_DemiPlayer, 20);

works fine for me

@Myriad Didn't work for me.

How did you know that 2061 == SP_TOLERANCE_RACE?
Where the emulator keep the code from each item_bonus?

If I take a look into bAddRace C++ code may I could make it works,
Could you tell me where to find?

Thx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now