• 0
Sign in to follow this  
Followers 0
shakasinx

Error ao compilar

Question

Preciso de uma ajuda de vocês.

Eu comprei um servidor completo, já importei as tabelas, o hexed abre normalmente, porém ao ligar o runserver.bat sou informado que não foi encontrado map-server,char-server, e login-server, então deu a entender que eu precisaria compilar, foi o que fiz, compilei e o login-server,char-server estão OK! Somente o map-server que não funcionou.

Então eu voltei no Visual Studio e vi que realmente existe erros na compilação envolvendo o map-server.


Os erros obtidos através da compilação foram esses

https://i.imgur.com/YwipVIB.png

 

Alguém sabe como solucionar?  Pelo que eu vi, todos os erros apontam para atcommand.c, se alguém puder me ajudar e quiser olhar o arquivo eu agradeço infinitamente, deixei o arquivo anexado na postagem

------------------------------------------------------------------------------------------------------------------------------------------------------

I need your help.

I bought a full server, I already imported the tables, the hexed opens normally, but when I connect runserver.bat I am informed that no map-server, char-server, and login-server were found, so it implied that I would need to compile , that's what I did, compiled and the login-server, char-server are OK! Only the map-server that did not work.

So I came back in Visual Studio and saw that there are actually compile errors involving the map-server.


The errors obtained through compilation were those:

 

https://i.imgur.com/YwipVIB.png

Does anyone know how to fix it? From what I've seen, all errors point to atcommand.c, if anyone can help me and want to look at the file I thank infinitely, I left the attached file in post

 

 

>>>>>  atcommand.c  <<<<<<

Edited by shakasinx

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

Try to download Herc from the repository and follow all the steps again to run your server. If it works (Of course it will) the emulator that you bought is not working properly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0