• 0
Sign in to follow this  
Followers 0
fourxhackd

@whodrops repeatedly show different values for single mob

Question

When I inspect @mi Mavka to see the droprates of a mob, it shows the following:

mavka1.PNG.69a614a166fe846e8ccee7b8589c2e05.PNG

We can see that Witherless Rose drops at a 9.00% chance.

However, when @whodrops is executed, the Mavka is shown multiple times with various drop rates:

mavka2.PNG.35cb2406939dd03b61fddf7564d40491.PNG

 

Please take note that above, I made a source edit so that the mob ID will be shown beside the name of the mob. Unusually, it shows a drop rate of 16.80%, 16.20%, and 9.00%.

I was  expecting that it should show the Witherless Rose at 9.00% chance ONCE.

 

Do you guys have some idea why this is happening? I've been reading up on @whodrops and how the item_data struct is loaded, but i'm kind of stuck.

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

probably you did error in your mod?

try test on clean hercules

Share this post


Link to post
Share on other sites
  • 0

This also normally happen when you do changes the drops / mob_db configuration then you do @reloadbattleconf or @reloadmobdb then @mi, try to restart your server that error will be gone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0