Neo

NEMO - Client Patcher

532 posts in this topic

@NEMO hello sir can you please check "Remove GM Sprites" when i apply this to 2013-06-05 there's a bug with GM Characters heads gone shaky and it's weird LOL.

Share this post


Link to post
Share on other sites

Mr. Nemo please add also "Use Arial on All Langtypes" and Custom "Data.ini" and Custom "Clientinfo.xml" :D

 

Thank you so much

Edited by iZeal

Share this post


Link to post
Share on other sites

disable hallucination screen broken?

 

i diff it to 2012-04-10aragexe

 

still crash client after i diff disable hallucination screen

 

Edited :

 

Sorry, problem is because i use "Increase Attack Display"

 

sir, i got a new broken diff in client 2012-04-10aragexe.exe

 

"Increase Headgear ViewID" its not work, when i tried to using new headgear, (ViewID up to 1000++), my client crash, and then when i use WeeDiffPatcher, its work.

Edited by ahmadshidqi

Share this post


Link to post
Share on other sites

What about Enable Unlimited Loading Screens?  :meow:

 

Could you please?

 

51 piece.

moving safely in my environment.

n32edl.png

Edited by Lilystar

Share this post


Link to post
Share on other sites

Cannot use some Diff in a recently date.


Failed Diffs.
Restore Login Window


Failed Client.
2014-06-12aRagexe
2014-06-13aRagexe


Failed Diffs.(RE)
Disable Ragexe Filename Check
Restore Login Window


Failed Client.(RE)
2013-07-10cRagexeRE
2013-12-11eRagexeRE
2014-03-05bRagexeRE
2014-04-02fRagexeRE
2014-04-16aRagexeRE

 

ng7oeq.jpg

Edited by Lilystar

Share this post


Link to post
Share on other sites

Cannot use some Diff in a recently date.

 

Failed Diffs.

Restore Login Window

 

Failed Client.

2014-06-12aRagexe

2014-06-13aRagexe

 

Failed Diffs.(RE)

Disable Ragexe Filename Check

Restore Login Window

 

Failed Client.(RE)

2013-07-10cRagexeRE

2013-12-11eRagexeRE

2014-03-05bRagexeRE

2014-04-02fRagexeRE

2014-04-16aRagexeRE

 

ng7oeq.jpg

 

are they unpacked?

Share this post


Link to post
Share on other sites

are they unpacked?

I have started using the launcher.

(Because cannot use the Restore Login Window)

But there is many unknown packets.

 

 

 

o01etd.jpg

 

 

 

Perhaps, use thing is not packing from the original.

Edited by Lilystar

Share this post


Link to post
Share on other sites
Hello Neo! 
I'm trying to use the "enable custom shield", but I'm having problems! 
The shields do not appear! Actually I should change something in the files "iteminfo.lub" or somewhere else? 
I put the shieldtable.lub in the datainfo folder and diffed the client already. There is something that is missing? 
 
Thank you for understanding.
 
Edited by luis.seifert

Share this post


Link to post
Share on other sites

@evilpuncker: dunno about RE clients but the main clients mentioned are not packed. Latest usable Ragexe client is 2014-06-13a. I know about the Restore Login Window issue its just a small fix will push that later today.

 

@luis : I need to check that patch. People have been saying they are facing issue with shields not appearing at all.

Share this post


Link to post
Share on other sites

Hi nemo

 

i use client 2012-04-10aragexe.exe

 

"Increase Headgear ViewID" its not work, when i tried to using new headgear, (ViewID up to 1000++), my client crash, and then when i use WeeDiffPatcher, its work.

 

can you help me? :(

Share this post


Link to post
Share on other sites

The following is the output produced by using the 'Extract msgstringtable'.

 

μ¿AC CI½E´I±i?#
(A5 EC A2 AF 41 43 20 43 49 A8 F6 45 A2 A5 49 A1 BE 69 3F)

 

But, the 'encoding' has been wrong, you should see the following output to be normal.

 

 

 동의 하십니까?#
(B5 BF C0 C7 20 C7 CF BD CA B4 CF B1 EE 3F)

 

 

How do I make the output above normal?

Share this post


Link to post
Share on other sites

hmm thats weird maybe i should fetch the Hex pattern and convert to string. Anyways i have been planning to do something with that addon. :)

Share this post


Link to post
Share on other sites

hmm thats weird maybe i should fetch the Hex pattern and convert to string. Anyways i have been planning to do something with that addon. :)

 

 

Hey there Neo! I want your help and to help you with the shared palette diff, it seems to be not working at all, some info:

 

I'm using 2014-02-05bRagexe and have been trying this diff since NEMO went out I guess, I've tried different settings (both diff related and pal related and whatever else you may imagine of lol) but I got no success in getting them working at all, I have 700 palettes, but they just don't display ingame, there are some that do work, I've put some samples so you can check out:

 

not working: http://depositfiles.org/files/ww6j1ya5c

working: http://depositfiles.org/files/qxhf16sex

 

they used to work with all my old clients and the diff from weediff or whatever it was called lol, but now with a 2014 client diffed by nemo it just don't work with either a or b option (yes, I made sure that every file name and place was correct and etc)

 

PS: seems like hair color works for some, but dye color not work at all, only the "official" ones (1, 2, 3 etc?) but them it wont change, I don't know what to do, so I'm here to ask for your help and I'm here to provide any info you want, thanks in advance and thanks for this great tool!

Share this post


Link to post
Share on other sites

When you save the file, it seems to be able to minimize data loss during the 'encoding' to the store to 'Stream' approach rather than text files.

파일을 저장할 때, text파일이 아닌 'Stream'방식으로 저장을 하여 '인코딩'도중에 손실되는 데이터를 최소화 할 수 있을 것 같습니다.

 

Than, seems not bad even ways to output euc-kr (51949) or 949 (ANSI) method in the future.

이후에 euc-kr(51949) 또는 949(ANSI) 방식으로 출력시키는 방안도 나쁘지 않은 것 같습니다.

Share this post


Link to post
Share on other sites

Nemo please repl my question :( i need your info :("i use client 2012-04-10aragexe.exe "Increase Headgear ViewID" its not work, when i tried to using new headgear, (ViewID up to 1000++), my client crash, and then when i use WeeDiffPatcher, its work. can you help me? :("

Share this post


Link to post
Share on other sites

@ Neo 

- i have a question when i enabled SSO Login enabled there's an error that appears.. can you help me using 2014-06-08 client.

- can you fix the SSO login enabled thanks.

Share this post


Link to post
Share on other sites

I got a problem in diffting "2012-04-10aRagexeRE" .

 

post-6482-0-28788900-1407912376_thumb.jpg

As you can see on the screenshot skills are not translated.

I am using the https://github.com/ROClientSide/Translation/tree/master/Data/ for my main grf but its no good. Previously I use this data to "2012-04-10aRagexe" and it works.

 

Here are my diff:

2 Chat Flood Allow8 Custom Window Title9 Disable 1rag1 type parameters (Recommended)13 Disable Ragexe Filename Check (Recommended)15 Disable HShield (Recommended)20 Extend Chat Box21 Extend Chat Room Box22 Extend PM Box24 Fix Camera Angles (Recommended)28 Increase Headgear ViewID30 Increase Zoom Out 50%33 Always Call SelectKoreaClientInfo() (Recommended)34 Enable /showname (Recommended)36 Read msgstringtable.txt (Recommended)37 Read questid2display.txt (Recommended)38 Remove Gravity Ads (Recommended)39 Remove Gravity Logo (Recommended)40 Restore Login Window (Recommended)41 Disable Nagle Algorithm (Recommended)44 Translate Client (Recommended)48 Use Plain Text Descriptions (Recommended)50 Skip License Screen53 Use Ascii on All Langtypes (Recommended)61 Disable Packet Encryption (Recommended)63 Use Official Cloth Palettes64 @ Bug Fix (Recommended)69 Extend Npc Dialog Box200 Enable Multiple GRFs - Embedded71 Ignore Missing File Error72 Ignore Missing Palette Error73 Remove Hourly Announce (Recommended)75 Enable Flag Emoticons84 Remove Serial Display (Recommended)86 Only First Login Background88 Allow space in guild name90 Enable DNS Support (Recommended)97 Cancel to Login Window (Recommended)

 

 

I don't know if the problem is on the client that I used or there is a problem with this diff "200 Enable Multiple GRFs - Embedded"
 
Note: I use the both "Enable Multiple GRFs" still don't work.

I hope you can fix it Sir NEMO :)

 

 

I just fixed my problem lately by downloading the github instead of mediafire link and you should update it sir.

Now I got this problem when I patch 2012-04-10aragexe. Skill names and decription are not translated.

attachicon.gifscreenHercules002.jpg

Get the translated data folder:

https://github.com/ROClientSide/Translation/tree/master/Data/

 

 

Share this post


Link to post
Share on other sites

GM's Hair style in Client 2012-04-10 are not aligned properly when diffed with Remove GM Sprite.

 

works fine if I remove it in clientinfo.

 

   	 <yellow>        </yellow>

Share this post


Link to post
Share on other sites

Hi Guys, Please post any bugs you find and already found in GitHub. Its easier for me to track them there ^_^.

I might end up not seeing something because of lot of posts here. :D

 

quesoph this is already a known bug in that patch for long time. hmm so yellow tag is working? I thought the tag was not working.

Share this post


Link to post
Share on other sites

Hi Guys, Please post any bugs you find and already found in GitHub. Its easier for me to track them there ^_^.

I might end up not seeing something because of lot of posts here. :D

 

quesoph this is already a known bug in that patch for long time. hmm so yellow tag is working? I thought the tag was not working.

 

Hi Neo, I posted some Issues i've encountered. Kindly check it. Thank you! :)

Share this post


Link to post
Share on other sites

 

GM's Hair style in Client 2012-04-10 are not aligned properly when diffed with Remove GM Sprite.

 

works fine if I remove it in clientinfo.

 

   	 <yellow>        </yellow>

same with 2013-06-05 and 2013-08-07

Share this post


Link to post
Share on other sites

Hi Guys, Please post any bugs you find and already found in GitHub. Its easier for me to track them there ^_^.

I might end up not seeing something because of lot of posts here. :D

 

quesoph this is already a known bug in that patch for long time. hmm so yellow tag is working? I thought the tag was not working.

If you remove your aid in yellow tag, it'll work just fine.. :)

Share this post


Link to post
Share on other sites

@NEMO I wish you could also add "Arial on All Langtypes" 

why not use "Use Custom Font" and select Arial for the font. I removed the patch since it was redundant with that one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now