• 0
Sign in to follow this  
Followers 0
leloush

[Hello]This is a raid for party i made.

Question

can someone please make it more easy to configure.
and add some features on it.
im so lack of knowledge when it comes in squeezing the script commands.
and oh. please be kind to me this is my 1st time trying to make one. but lack of skill.

 

 

for the script:

1) need to add more levers ( up to 7 or atleast 5 lever ) this lever is hidden until they wiped all the mobs from the current lever where the party is. example lever 1 has been pulled. they need to wiped all the mobs. before the next lever will appear.
2) is it possible to make a lives for this event. for example there is 20 participants. and they only have 15 lives together. 20 particapants if anyone of them died. it will cost 1 life so there will be 14 lives left. and so on
if they consumed all this 15. they will lose their chance to get into the boss and will be warped out.
3) if u want to add some more features on it. it will help alot.

4) and oh. ofc i this raid will required the party leader to bring 1 raid seal to generate the dungeon.
i already made it.

im lack of knowledge to complete this script.

if u want to modify or rewrite to make it more efficient. (thank you so much.)

if no one wants. (thank you also.)  :meow:

 

 

 

 

 

 

raidparty.txt

Share this post


Link to post
Share on other sites

21 answers to this question

  • 0

im using 12535 annie

you mean you are still using the damn old emulator where has_instance2 is not supported ?

try check your script_commands.txt and see your emulator support has_instance2 or not

https://github.com/HerculesWS/Hercules/blob/master/doc/script_commands.txt#L7971

 

maybe try change has_instance2( "guild_vs2" ) into instance_id(1)

otherwise, I can't support people using such old emulator

 

#define MAX_PARTY 12

inside mmo.h

 

@Hadeszeus

turn off the gvg mapflag

Edited by AnnieRuru

Share this post


Link to post
Share on other sites
  • 0

its just for example annie..

and yeah i never tought about that... 20 something.... ahah :P

well.. if there's a possible way to have 20 in a party.. ill look for it.. i saw something like this before.. but idk where and when...

 

OnPCDieEvent:
if ( strcharinfo(3) == has_instance("guild_vs2") ) {
instance_attach has_instance2( "guild_vs2" );   <---
'lives--;

btw i got an error in line 80 ... idk the console asking me to put ; but i think there's already semicolon in that line.

im using 12535 annie

me too.. im expecting that you was the one will give a hand here coz this past few days your the one who's very active in script request / support ..... but im not the guy will put a name on my topic...
otherwise ppl will get mad at me ofc ( those have knowledge in scripting too )... :meow:
Edited by leloush

Share this post


Link to post
Share on other sites
  • 0

http://upaste.me/d59f108154ef949e3

 

@leloush

how issit possible to have 20 participants when the maximum party members can have is 12 ?

 

and ...

 

@karazu

how can you read my mind ? :hmm:

 

I tested it and working fine. However, inside the Event map I can hit my party member and once killed he will be warp back outside the event map..

Share this post


Link to post
Share on other sites
  • 0

 

im using 12535 annie

you mean you are still using the damn old emulator where has_instance2 is not supported ?

try check your script_commands.txt and see your emulator support has_instance2 or not

https://github.com/HerculesWS/Hercules/blob/master/doc/script_commands.txt#L7971

 

maybe try change has_instance2( "guild_vs2" ) into instance_id(1)

otherwise, I can't support people using such old emulator

 

@Hadeszeus

turn off the gvg mapflag

yeah im still using it :P and im sorry for that.. soon im gonna move in the latest one.. well i have the latest one, i just working with the old ones.

 

gonna try that instance_id(1)

thnks.

 

 

 

@edit

instance_id(1) doesnt work

 

maybe its time for me to move on on latest revs.

 

thank you so much annie.

 

Edited by leloush

Share this post


Link to post
Share on other sites
  • 0

 

im using 12535 annie

you mean you are still using the damn old emulator where has_instance2 is not supported ?

try check your script_commands.txt and see your emulator support has_instance2 or not

https://github.com/HerculesWS/Hercules/blob/master/doc/script_commands.txt#L7971

 

maybe try change has_instance2( "guild_vs2" ) into instance_id(1)

otherwise, I can't support people using such old emulator

 

#define MAX_PARTY 12

inside mmo.h

 

@Hadeszeus

turn off the gvg mapflag

 

 

annie.. i tried in 13777 the npc now working.. however.. i recieve this error after the warper accept the "red potion" and warp my party to the event map

 

 

 

@EDIT: forget about the error in warper annie, i already fixed that.. im just wondering why im stuck on Prepare for Lv1 Mobs.    after that nothing happens.

 

no error in console.

 

 

 

 

Edited by leloush

Share this post


Link to post
Share on other sites
  • 0

 

 

im using 12535 annie

 

maybe its time for me to move on on latest revs.

 

thank you so much annie.

 

 

lool doubt it

 

well i know sometimes it's good to keep old versions, for me if it works and isnt giving me a lot of problems then i won't update, maybe i don't like some features too lol like the race players x_____X i really don't like it lol so i keep my old version, but! don't use sich oooold version D: just saying hehe

Share this post


Link to post
Share on other sites
  • 0

 

 

 

im using 12535 annie

 

maybe its time for me to move on on latest revs.

 

thank you so much annie.

 

 

lool doubt it

 

well i know sometimes it's good to keep old versions, for me if it works and isnt giving me a lot of problems then i won't update, maybe i don't like some features too lol like the race players x_____X i really don't like it lol so i keep my old version, but! don't use sich oooold version D: just saying hehe

yeah me either.. but the thing is.. i really want tis script to use.. :P

 

the race system? haha i loved them so much.. bad news is i cant afford them :P

Edited by leloush

Share this post


Link to post
Share on other sites
  • 0

ah isee, the one u talking is "size" ? 

well my bad(misread) i tought the "elemental race. - the one with costum item that will transform ur appearance into something"

Edited by leloush

Share this post


Link to post
Share on other sites
  • 0

ah isee, the one u talking is "size" ? 

 

well my bad i tought the "race system - the one with costum item that will transform ur appearance into something"

 

nope o: i was refering ro race, RC_Player @[email protected]

 

now that items sounds good

 

well i'm leaving

 

see you tc

Share this post


Link to post
Share on other sites
  • 0

One more question. Im trying to add a timetick to avoid multiple entries of the players who already joined or part of a party.

How to make it work.

you mean add a deny timer to those players who already join the event

then if they already played, they can't play again in another 3 hours ?

 

 

 

@EDIT: forget about the error in warper annie, i already fixed that.. im just wondering why im stuck on Prepare for Lv1 Mobs.    after that nothing happens.

have you tried debug the script ?

like put debugmes on every single variable in the script

 

otherwise, post your edited script

Share this post


Link to post
Share on other sites
  • 0

 

One more question. Im trying to add a timetick to avoid multiple entries of the players who already joined or part of a party.

How to make it work.

you mean add a deny timer to those players who already join the event

then if they already played, they can't play again in another 3 hours ?

 

 

 

>>>@EDIT: forget about the error in warper annie, i already fixed that.. im just wondering why im stuck on Prepare for Lv1 Mobs.    after that nothing happens.

have you tried debug the script ?

like put debugmes on every single variable in the script

 

otherwise, post your edited script

 

 

HI Annie It post this error, did I missing something, I am already setup your plugins getmemberaid.

 

[¾¯¸æ]: script_get_val: cannot access instance variable ''round', defaulting to 0[¾¯¸æ]: script_get_val: cannot access instance variable ''killed', defaulting to 0[¾¯¸æ]: script_get_val: cannot access instance variable ''total', defaulting to 0[¾¯¸æ]: script_get_val: cannot access instance variable ''round', defaulting to 0[¾¯¸æ]: script_get_val: cannot access instance variable ''round', defaulting to 0[´íÎó]: script_set_reg: cannot write instance variable ''round', NPC not in a instance![´íÎó]: script_set_reg: cannot write instance variable ''killed', NPC not in a instance![´íÎó]: script:getvariableofnpc: can't find npc Raid

Manifestations, I entered the space on RAID moment was brought up.

 

It's sloved in last SVN. But I got another problem.

 

[´íÎó]: script:getvariableofnpc: can't find npc Raid[³ý´íģʽ]: Source (NPC): Raid_ins at 1RAID (0,0)

I can join instances map, but have no npc,

 

It's sloved. I change the txt type to unix. 

Edited by 安赫尔

Share this post


Link to post
Share on other sites
  • 0

 

One more question. Im trying to add a timetick to avoid multiple entries of the players who already joined or part of a party.

How to make it work.

you mean add a deny timer to those players who already join the event

then if they already played, they can't play again in another 3 hours ?

 

 

 

>@EDIT: forget about the error in warper annie, i already fixed that.. im just wondering why im stuck on Prepare for Lv1 Mobs.    after that nothing happens.

have you tried debug the script ?

like put debugmes on every single variable in the script

 

otherwise, post your edited script

 

annie honestly i dont know how to put debugmes on each variable.

in the script.. i just edit the minimum to 2 players..

 

that's all, no more no less..

Share this post


Link to post
Share on other sites
  • 0

there are 2 other members has already using this script and they say its working fine

so the problem is only at your side

 

anyways, I make the debugmes for you, check your map-server.exe and display until which line

 

http://upaste.me/a73f1086889cc8be0

[Debug]: script debug : 0 110000776 : OnInstanceInit working correctly[Debug]: script debug : 0 110000776 : round 1 is able to start correctly[Debug]: script debug : 0 110000776 : monster ID 1001 can be spawn correctly[Debug]: script debug : 0 110000776 : monster ID 1001 can be spawn correctly[Debug]: script debug : 2000000 110000776 : round 2 is able to start correctly[Debug]: script debug : 0 110000776 : monster ID 1031 can be spawn correctly[Debug]: script debug : 0 110000776 : monster ID 1032 can be spawn correctly[Debug]: script debug : 2000000 110000776 : round 3 is able to start correctly[Debug]: script debug : 0 110000776 : monster ID 1111 can be spawn correctly[Debug]: script debug : 0 110000776 : monster ID 1113 can be spawn correctly[Debug]: script debug : 2000000 110000776 : The party can end this instance correctly
should be like this

Share this post


Link to post
Share on other sites
  • 0

Strange

 

Annie your Script . Sometimes it can work , sometimes not.

 

 

In script many '  . does '  can be replace?

 

I think this symbol is not good to support .,

 

Always post this

 

[¾¯¸æ]: script_get_val: cannot access instance variable ''round', defaulting to 0[¾¯¸æ]: script_get_val: cannot access instance variable ''round', defaulting to 0[¾¯¸æ]: script_get_val: cannot access instance variable ''round', defaulting to 0

Share this post


Link to post
Share on other sites
  • 0

I just recheck the script, and I forgot to put mapflags ... hahaha

just edited the script

http://upaste.me/d59f108154ef949e3

 

it seems hercules has a special mapflag 'src4instance', which means, flag that map as an instance map

it will always redirect players or monsters to the instanced map instead of source map

 

not sure it can fix this ... instance variable or not ... though by reading source ... I don't think so ...

 

 

try post your edited script and see ? I can read chinese

Share this post


Link to post
Share on other sites
  • 0

Hello Annie is this the  ID and number of Monsters?

 

    setarray .round1[0], 1001,20, 1001,20;	setarray .round2[0], 1031,20, 1032,20;	setarray .round3[0], 1111,20, 1113,20;	.totalround = 3; 

 


 


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0