Neo

PEEK - Successor to Yommy's Packet Analyzer

46 posts in this topic

I tried it like a week ago when I saw your repo and it didn't work.  :)

Edit: I am getting a "No match found in Length Table for Packet 0x7f57". 

Edited by Hououin

Share this post


Link to post
Share on other sites

does it support new kRO clients? if possible the latest one?

 

:meow:

Share this post


Link to post
Share on other sites

does it support new kRO clients? if possible the latest one?

 

:meow:

 

i tested it on a 2014-02-05 Ragexe , worked without a problem

Share this post


Link to post
Share on other sites

I tried it like a week ago when I saw your repo and it didn't work.  :)

Edit: I am getting a "No match found in Length Table for Packet 0x7f57". 

which client date did u use?

Share this post


Link to post
Share on other sites

I was wondering if it is possible to get npcs equal dialogues of yommy who worked in the past, I have account on kro and wanted to pick up some npcs.

Share this post


Link to post
Share on other sites

 

I tried it like a week ago when I saw your repo and it didn't work.  :)

Edit: I am getting a "No match found in Length Table for Packet 0x7f57". 

which client date did u use?

2013-08-07a

Share this post


Link to post
Share on other sites

I think you are trying to use a packed client from kRO which can't be used for extracting packet keys.

 

 

 

 

I tried it like a week ago when I saw your repo and it didn't work.  :)

Edit: I am getting a "No match found in Length Table for Packet 0x7f57". 

which client date did u use?

2013-08-07a

thats odd I have run this on 2013-08-07a mostly. That packet id itself seems wrong which means there is something wrong with the encryption.

Is it always showing error for same packet?

 

 

I was wondering if it is possible to get npcs equal dialogues of yommy who worked in the past, I have account on kro and wanted to pick up some npcs.

maybe but which client do you plan to use for that?. the stock Ragexe would be packed and we need to do stuff in the client like Encryption key & Packet Length extractions.

Share this post


Link to post
Share on other sites

 

I think you are trying to use a packed client from kRO which can't be used for extracting packet keys.

 

 

 

I tried it like a week ago when I saw your repo and it didn't work.  :)

Edit: I am getting a "No match found in Length Table for Packet 0x7f57". 

which client date did u use?

2013-08-07a

thats odd I have run this on 2013-08-07a mostly. That packet id itself seems wrong which means there is something wrong with the encryption.

Is it always showing error for same packet?

Yeah its the same error everytime. 

Share this post


Link to post
Share on other sites

Awesome release and thanks to the contributor of this project good luck guys  :wub:

Share this post


Link to post
Share on other sites

Wow how did I miss this??? Really nice tool but im running into issues. I used a 2013-12-23cRagexe client and upon selecting my character at the character select screen I get a error message saying "No match found in Length Table for Packet 0x68a" which is strange since no such packet exists....I think. When the error happens the program closes. No way to avoid the error or continue capturing. Even pausing before it happens doesn't help. Also when clicking the start analyzer it doesn't launch the client. Im using the restore login window patch if this affects anything.

 

I tried using this to solve a issue with some packets with the client as the shuffled packets may not be right which are causing issues with whispering to other players and not being able to feed homunculus.

Share this post


Link to post
Share on other sites

Wow how did I miss this??? Really nice tool but im running into issues. I used a 2013-12-23cRagexe client and upon selecting my character at the character select screen I get a error message saying "No match found in Length Table for Packet 0x68a" which is strange since no such packet exists....I think. When the error happens the program closes. No way to avoid the error or continue capturing. Even pausing before it happens doesn't help. Also when clicking the start analyzer it doesn't launch the client. Im using the restore login window patch if this affects anything.

 

I tried using this to solve a issue with some packets with the client as the shuffled packets may not be right which are causing issues with whispering to other players and not being able to feed homunculus.

I tried to use with 2013-12-23c and got this issue as well, I guess the problem is that the only release of this client is packed and if you try to extract its packet-list using the current hex pattern it won't work, try using this tool with a more current unpacked client from k3dt and it might work :)

Share this post


Link to post
Share on other sites

The client wasnt packed. If it was I wouldn't be able to patch or use it at all. I extracted it from the rgz patch file and it came out as a 6.58 MB file which is clear to see text and stuff in with a hex editor.

Share this post


Link to post
Share on other sites

*BUMP*

 

Is it possible to get a update for this? Its a really nice tool and I would hate to see it die off from lack of updates. Or some way to resolve the weird abnormally.

Share this post


Link to post
Share on other sites

yea need to check this. actually i need to update the packet length extractor a bit (maybe the issue would also get resolved with that).

Share this post


Link to post
Share on other sites

Thank you. If you need any data or info, feel free to ask and ill help however I can.

Share this post


Link to post
Share on other sites

I have updated the scripts in PEEK. Please check and see if you are still getting issues.

Share this post


Link to post
Share on other sites

Tested and still getting the "No match found in Length Table for Packet 0x68a" for the 2013-12-23cRagexe client when selecting character on the character selection screen.

Share this post


Link to post
Share on other sites

@@Neo @@Yommy

i have this bug.

PEEK isn't running? Or you forgot to copy the dll that is provided with PEEK?

Share this post


Link to post
Share on other sites

 

@@Neo @@Yommy

i have this bug.

PEEK isn't running? Or you forgot to copy the dll that is provided with PEEK?
  1. Copy all files in the GIT in my RO folder.
  2. Select my executable in Peek.
  3. Start my executable.
  4. Bug port.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now