rans

Members
  • Content Count

    341
  • Joined

  • Last visited

Everything posted by rans

  1. How can i disable Tarot skill to destroy the equipment even if the target has FCP? I already set the protection sc_config.txt to be undispelable but it still destroy the equipment
  2. don't know if this is a bug or intended. if for example you have a sleep(sometimes also in gettimetick) in your script and player immediately logout while there is a sleep waiting in that player he won't be able to reconnect. the server will throw him a "Server still recognizes your last log-in. Please try again after a few minutes" the player will not be able to connect for like 30-60 seconds. Whats weirder is this only happens to low end machines. (i tried it on a kvm 4gb 2core - and this behavior ddnt show.) tested this using the latest herc the way i tested this is I use the npc/custom/healer.txt and added a sleep 1000 right after the variable inits. spam it then quickly character select.
  3. This seems to be a problem with my Host. but still unresolved commenting for future reference
  4. Hi, Its broken on the lastest version of herc. it doesnt compile and showing error something about you cant declare struct on statement.
  5. Can anyone please make a plugin for this? A Guild Master Professor can use emergency call while walking. but only if he is soul linked. thanks!
  6. Im not sure if this is the right section or should be move on client. It happen randomly but more often in my server (version v2019.05.05+2 ) client (2018-04-18bRagexeRE) as you can see here. My character is already logout, but the map-server is still reading my character for like a minute before it kick the character. even if i try to login i will get this message. for several times. Usually it should kick the player inside if i re-login, right? but this one won't kick the player i have to wait for like a minute before i login. this is a big problem in my server when WOE because they have to relog right after they use guild skills. i already set the option drop_connection_on_quit: true
  7. So all my custom robe sprite went missing (in-game view) but on alt+q and character select it shows. spriterobename.lub spriterobeid.lub but all default sprite robes seems to be working fine. only the custom have problem. is there added steps in adding sprite robes?
  8. Hercules code is neat and much nicer than others.
  9. I see the patch being "successful" for 2018 clients but im not so sure about if its already fixed because last month i tried 2017 clients with enable 64k but after 30+ hstyle in-game will randomly crash. I dont really know how to exactly reproduce but it just happen randomly. anyone here already tried the patch in newer clients?
  10. Hi, Im not really familiar with Git or i mean im newbie. I just want to know how could I create my own repository of hercules but will still get update from the main repository of hercules when i git pull? if you could elaborate of what and how to do it specifically it would be very appreciated. thank you!
  11. try comparing it with a default npc and slowly rotate it. there is a offset where the custom added will face direction quicker than it should be. just like in the photo i posted.
  12. here npc_bascojin.act npc_bascojin.spr
  13. the poring is a default one and the bascojin i downloaded. i've also encountered this problem to other custom npc from the download section.
  14. This duplicate npc (the bascojin and poring) is facing the same direction in the script (4) but if you rotate camera there is a small offset. the custom added npc will switch face faster than the normal.
  15. wondering if anyone has 2018 version for this?
  16. I'm a little bit confuse on this How can i use the env MYPLUGINS? all the guides about adding plugin uses the MYPLUGIN = I'm just curious. thank you
  17. rans

    Hercules.ws

    Cleaned up my browser so i forgot that hercules change their domain long time ago from hercules.ws to herc.ws but when i tried to use hercules.ws it redirected me to rathena lol
  18. hello, its seems that when my spritefile name has "_" in the converted iteminfo it's translated into space. is it normal? or there is a settings also for that?
  19. I ddnt notice that. thanks i change it to 2016
  20. I use the tool mergeidnum.bat to convert my idnum into iteminfo but after it i'm getting this 7th argument is must number error. i've attached my iteminfo.lub itemInfo_new.lub
  21. i did try to add a dummy sprite to that missing file. and it seems to be a job sprite. but when i try to change to another job it resulted to another missing file error.