Blip

Members
  • Content Count

    11
  • Joined

  • Last visited

  1. I started using first/second job skills (I even use some Quest-Skills to make a Tree), and everything worked pretty well. Until... i tried to do the same with Third-Job skills. This is what i did on my client, after starting over again: lua filesskillinfozskilltreeview.lub [JOBID.JT_NOVICE] = { [0] = SKID.NV_BASIC, [7] = SKID.NV_FIRSTAID, [14] = SKID.NV_TRICKDEAD [15] = SKID.LG_EXEEDBREAK, [22] = SKID.RK_IGNITIONBREAK, }, lua filesskillinfoskilltreeview.lub [0] = { {"NV_BASIC", 1; Pos = 0, MaxLv = 9, NeedSkillList = {}}, {"NV_FIRSTAID", 142; Pos = 7, MaxLv = 1, NeedSkillList = {}}, {"NV_TRICKDEAD", 143; Pos = 14, MaxLv = 1, NeedSkillList = {}} {"LG_EXEEDBREAK", 2316; Pos = 15, MaxLv = 5, NeedSkillList = {}}, {"RK_IGNITIONBREAK", 2006; Pos = 22, MaxLv = 5, NeedSkillList = {15}}}, lua filesskillinfozskillinfolist.lub (Deleting the requirements) [SKID.LG_EXEEDBREAK] ={ "LG_EXEEDBREAK", SkillName = "Exceed Break", MaxLv = 5, SpAmount = { 20, 32, 44, 56, 68, }, bSeperateLv = true, AttackRange = { 1, 1, 1, 1, 1, },}, & (Adding new requirements) [SKID.RK_IGNITIONBREAK] ={ "RK_IGNITIONBREAK", SkillName = "Ignition Break", MaxLv = 5, SpAmount = { 35, 40, 45, 50, 55, }, bSeperateLv = true, AttackRange = { 1, 1, 1, 1, 1, }, _NeedSkillList = { { SKID.LG_EXEEDBREAK, 5 }, },}, Server changes (I dont think there is a problem here but im sure someone is going to ask for it): dbreskill_tree.conf Novice: { skills: { NV_BASIC: 9 NV_FIRSTAID: 1 NV_TRICKDEAD: 1 WE_BABY: 1 WE_CALLPARENT: 1 WE_CALLBABY: 1 ALL_INCCARRY: 1 LG_EXEEDBREAK: 5 RK_IGNITIONBREAK: { MaxLevel: 5 LG_EXEEDBREAK: 5 } }} And the results are: You can see than the leveling up works as intended, but the skills are in the Third Tab. This only happens when using Third-Job related skills. Also, i cant click on the Third Tab. I have to switch to a ThirdJob, clicking on the Third Tab and going back to Novice to see the tab. Anyone knows how to make them appear on the First/Second tab?
  2. Hace tiempo que estoy con una idea loca en la cabeza y necesito que, para el mismo, suceda algo cada X tiempo, unas 3 o 4 veces. ¿Que pasa?, esto se repetiría unas 60 veces, que pueden ser al mismo tiempo, con duraciones de hasta semanas. Por esta misma razón, me es de vital importancia hacer el scripting lo más dinámico que pueda. Yo no quiero 60 timers corriendo (Menos, todo el tiempo). Personalmente, odio los timers. Es tirar recursos por la ventana. Mi primera idea fue usar gettimestr, pero me dí cuenta que sólo existen dos tipos de variables; Interger y String, lo cual me complica la vida para realizar una comparación de tiempo de forma fácil y rápida. Ahora, hace poco, encontré los labels predefinidos de tiempo (OnClock, OnDay, etc), lo cual, me han servido mucho combinandolos con gettime(<tipe>). ¿Cual es el problema? No sé como funcionan las Labels especiales. ¿Quedan ejecutandose, a la espera?, ¿Funcionan como un sleep? Quizás esté un poco paranoíco... pero el dinamismo me parece algo primordial a la hora de escribir código. PD: También acepto ideas para hacer comparaciones de tiempo (?)
  3. I dont have any custom firewall, and windows firewall is always off. One of the things i tried was turning it on and make the exceptions for the Ports and programs, because i read somewhere about a weird bug than could keep the firewall on or something like that.
  4. change this one to plain IP address..unless you diff your client to accept DNS...then try again.. Using plain IP was my first, second and third try. You dont know how much i hate using No-IP or Hamachi. I just tried again just to be sure, using plain ip and diffing the client to not accept DNS... and then using the old one, who accept its. And then using No-IP again with the new and old one. Nothing.
  5. Hello everyone. First of all, my english sucks. I know, its a pain in the ass... but anyways, this is my first try to make a home server. Im trying to get it working in my house so i can test things easily. The problem is, than nobody else can connect to the server (Except me, Localhost). No errors in the consoles, and i have no clue. Its my first time using a RO Emulator, but it not my first time using MySQL or reading/using scripts, or codes... i dont even know what word you use for this. This are some thigs i have checked: Ports are OK (I tested it with an old VB6 chat, with a friend) I tried using No-IP and Hamachi. (Actually using NO-IP) I have tried using 2014-02-05bRagexe and 2013-12-23cRagexe. Re-Compiled from scratch. Making it all again. (Even Database) Everyone is using the same client. This one. I have tried not using the subnet.conf at all. I dont think i have any errors on this: confchar-server.conf // Character Server configuration file.// Note: "Comments" are all text on the right side of a double slash "//"// Whatever text is commented will not be parsed by the servers, and serves// only as information/reference.// Server Communication username and password.userid: <Blank>passwd: <Blank>// Server name, use alternative character such as ASCII 160 for spaces.// NOTE: Do not use spaces or any of these characters which are not allowed in // Windows filenames /:*?"<>|// ... or else guild emblems won't work client-side!server_name: AlphaRO// Wisp name for server: used to send wisp from server to players (between 4 to 23 characters)wisp_server_name: Server// Login Server IP// The character server connects to the login server using this IP address.// NOTE: This is useful when you are running behind a firewall or are on// a machine with multiple interfaces.login_ip: alpharo.servegame.com// The character server listens on the interface with this IP address.// NOTE: This allows you to run multiple servers on multiple interfaces// while using the same ports for each server.//bind_ip: 127.0.0.1// Login Server Portlogin_port: 6900// Character Server IP// The IP address which clients will use to connect.// Set this to what your server's public IP address is.char_ip: alpharo.servegame.com// Character Server Portchar_port: 6121 confmap-server.conf //--------------------------------------------------------------// Hercules Map-Server Configuration File//--------------------------------------------------------------// Note: "Comments" are all text on the right side of a double slash "//"// Whatever text is commented will not be parsed by the servers, and serves// only as information/reference.//--------------------------------------------------------------// Configuration Info//--------------------------------------------------------------// Interserver communication passwords, set in account.txt (or equiv.)userid: <Blank>passwd: <Blank>// Character Server IP// The map server connects to the character server using this IP address.// NOTE: This is useful when you are running behind a firewall or are on// a machine with multiple interfaces.char_ip: alpharo.servegame.com// The map server listens on the interface with this IP address.// NOTE: This allows you to run multiple servers on multiple interfaces// while using the same ports for each server.//bind_ip: 127.0.0.1// Character Server Portchar_port: 6121// Map Server IP// The IP address which clients will use to connect.// Set this to what your server's public IP address is.map_ip: alpharo.servegame.com// Map Server Portmap_port: 5121 confsubnet.conf // Subnet support file// Format is:// subnet: net-submask:char_ip:map_ip// you can add more than one subnet subnet: 255.255.255.0:alpharo.servegame.com:alpharo.servegame.com dataClientinfo.xml <?xml version="1.0" encoding="euc-kr" ?><clientinfo> <desc>Ragnarok Client Information</desc> <servicetype>korea</servicetype> <servertype>pk</servertype> <hideaccountlist /> <readfolder/> <connection> <display>AlphaRO</display> <desc>Version Alpha</desc> <balloon>Alpha RO Ballon</balloon> <address>alpharo.servegame.com</address> <port>6900</port> <version>20</version> <langtype>1</langtype> <registrationweb>https://www.google.com.ar/</registrationweb> <yellow> <admin>2000001</admin> <admin>2000002</admin> <admin>2000003</admin> </yellow> <loading> <image>loading00.jpg</image> <image>loading01.jpg</image> <image>loading02.jpg</image> <image>loading03.jpg</image> <image>loading04.jpg</image> <image>loading05.jpg</image> <image>loading06.jpg</image> <image>loading07.jpg</image> <image>loading08.jpg</image> <image>loading09.jpg</image> <image>loading10.jpg</image> </loading> </connection></clientinfo> The only funny thing i can find, is than i cant connect to my own server if i use anything else except pk (serverype), in the Clientinfo.xml. I cant even know why. I been trying to resolve this for weeks now, and i just cant find a way to make it work. I been using others Profiles on the Nemo-Mater. Tried to use others regions or langtype.. I hate asking for help, and i already been doing it in the Spanish forum. If anyone need more info, i would be glad to provied it. 98% of the server files are untouched. At this point, i cant tell if its a Client-Side issue, but im pretty sure it is.
  6. Hago un poquito de doble post, únicamente para bumpear el tema. El sclientinfo.xml no lo lee (Obviamente, como sospechaba). Me he vuelto a bajar el Hercules, y he modificado todo lo necesario antes de compilarlo (Apenas lo hice una vez sola. Imposibilitando que sea un error de este tipo), y siempre en tipo Release (Visual Studio 2012. Usando el Hercules-11.sln). Decistí con el .exe que estaba usando, y pase a usar el 2013-12-23c (Que es el que viene configurado en el servidor de hércules), para evitar ideas de que fuera por eso. Diffee con Nero, (casi) mismas opciones que arriba, con algunas variaciones con el único propósito de testeo. Recuperé un antiguo chat en VB6 que tenía del año del naupa, para testear los puertos con un amigo. Hubo conexiones exitosas, y también hemos probado mi No-IP. Luego he cerrardo un puerto y como era de esperarse no nos hemos podido conectar (Sólo para estar seguros que la prueba de puertos había sido exitosa). Con esto pasé a des-instalar el hamachi. Como lo odio. Lo que me queda hacer es el 3, de forma parcial. Que es, más bien, buscarme una combinación de settings que ya haya probado alguien y le haya funcionado sin error alguno (Como descarte final). Y el 5 (Que he pasado un poco de tanto testeo. Prefiero averiguar cómo funciona antes que probar 16x16x4 probabilidades, que sería lo necesario para descartar esto) Encima que aún no descubro porqué sólo acepta el servertype pk, dandome error cuando pruebo cualquier otra cosa. Mañana terminaré de probar eso, y lo postearé en el apartado de inglés. Desearme suerte
  7. Si que está, linea 20. 35 Read Data Folder First Pero, aun así. El clienfinfo.xml esta, tanto dentro del AlphaRO.grf como de la carpeta Data. De echo, en la carpeta Data sólo existen 3 tristes archivos. El clienfinfo.xml, el cskroption.lub y el csTownInfo.lub (Que, de echo, estaba intentando ver qué eran, y si ya los tenía en los lua o algo /heh). Y sí, me considero bastante meticuloso. Me gusta hacer las cosas bien, organizadas y con comentario. El intento de levantar el servidor, no viene sólo por las ganas, me gusta la idea de poder experimentar un poco, y ganar un poco de práctica. A fin de cuentas, un servidor tiene necesidades reales, y es algo que me va a servir bien como ejercicio. DATA.INI [Data]0=AlphaRO.grf1=rdata.grf2=data.grf El Data está bien. Está con los valores correctos (Según sé, el rango de valores es del 0-9, sin diffear). A lo sumo podría cambiarle el valor inicial por 1, pero... Así lo lee bien (Todas las texturas traducidas están ahí, y van genial). Pero la verdad, estoy tan desesperado que ya empiezo a probar cosas que no tienen sentido (A todos nos pasó de solucionar algo así.) Voy a probar con lo siguiente, y si no, al foro inglés. Dejar el confsubnet.conf de fábrica. Duplicar clientinfo.xml y cambiarle el nombre por sclientinfo.xml (Recuerdo haber leído esto en algún lado. No sé ni para qué sirve) Diffear el cliente con lo básico, que a la vez me permita ejecutarlo sin errores. (Parcial) Probar con un Ragexe.exe más viejo (Y recompilar. Buff) Probar, uno a uno, los 20 tipos de servicio y los 20 tipos de idioma del clientinfo.xml (Duplicandlo al sclientinfo.xml) No, no voy a hacer esto 400 veces. Sólo 20, tipo de servicio (región) = idioma. Volver a montar el server y la base de datos, compilando una única vez. Llorar Traducir mi anterior post al inglés y postearlo en el sub-foro en inglés. No sé. Me quedé despierto hasta super tarde. Cuando testee con gente, te aviso que paso XD (Y seguro se me ocurre algo más que probar)
  8. Revivo mi tema, esta vez por un tema de conexión. Logre setear el cliente. Funciona bien y sin error alguno. No me he querido poner a jugar mucho con las configuraciones porque... ¡Nadie más puede unirse a mi servidor!. Al principio he creído que era un tema de cofiguraciones, luego, de puertos. Incluso me instalé uno de estos programas llenos de spywares para abrir mis puertos porque manualmente no parecía surtir efecto. He llegado a activar mi firewall de windows, sólo para ponerle una whitelist de puertos y los 3 .exe de servidores. Usé No-IP, e incluso el odiado (Por mí, sobretodo) Hamachi. Cuando yo he podido unirme al servidor, mientras usaba la No-IP, tuve varias sospechas de que no eran los puertos. Cuando Hamachi no funcionó, estuve bastante seguro. Así que... ¡No sé!. Estoy seguro que se está olvidado un valor, pero no sé cual, ni en donde. Alguien que no tenga la cabeza tan quemada con esto (Seguro me responde sólo JaBote igual XD), ¿Me puede dar una mano?. Cuatro ojos ven más que dos. confchar-server.conf // Server Communication username and password.userid: <Blank>passwd: <Blank>// Server name, use alternative character such as ASCII 160 for spaces.// NOTE: Do not use spaces or any of these characters which are not allowed in// Windows filenames /:*?"<>|// ... or else guild emblems won't work client-side!server_name: AlphaRO// Wisp name for server: used to send wisp from server to players (between 4 to 23 characters)wisp_server_name: Server// Login Server IP// The character server connects to the login server using this IP address.// NOTE: This is useful when you are running behind a firewall or are on// a machine with multiple interfaces.login_ip: 25.189.240.75// The character server listens on the interface with this IP address.// NOTE: This allows you to run multiple servers on multiple interfaces// while using the same ports for each server.// bind_ip: 270.0.0.1// Login Server Portlogin_port: 6900// Character Server IP// The IP address which clients will use to connect.// Set this to what your server's public IP address is.char_ip: 25.189.240.75// Character Server Portchar_port: 6121 confmap-server.conf // Interserver communication passwords, set in account.txt (or equiv.)userid: <Blank>passwd: <Blank>// Character Server IP// The map server connects to the character server using this IP address.// NOTE: This is useful when you are running behind a firewall or are on// a machine with multiple interfaces.char_ip: 25.189.240.75// The map server listens on the interface with this IP address.// NOTE: This allows you to run multiple servers on multiple interfaces// while using the same ports for each server.// bind_ip: 270.0.0.1// Character Server Portchar_port: 6121// Map Server IP// The IP address which clients will use to connect.// Set this to what your server's public IP address is.map_ip: 25.189.240.75// Map Server Portmap_port: 5121 conflogin-server.conf // Login Server Portlogin_port: 6900 confsubnet.conf // Subnet support file// Format is:// subnet: net-submask:char_ip:map_ip// you can add more than one subnet subnet: 255.255.255.0:25.189.240.75:25.189.240.75 Perfil utilizado en NEMO-Master (2014-02-05bRagexe.exe) 2 Chat Flood Allow8 Custom Window Title9 Disable 1rag1 type parameters (Recommended)10 Disable 4 Letter UserCharacter Limit11 Disable 4 Letter UserID Limit12 Disable 4 Letter UserPassword Limit13 Disable Ragexe Filename Check (Recommended)14 Disable Hallucination Wavy Screen (Recommended)15 Disable HShield (Recommended)16 Disable Swear Filter19 Enable Title Bar Menu20 Extend Chat Box21 Extend Chat Room Box22 Extend PM Box24 Fix Camera Angles (Recommended)28 Increase Headgear ViewID31 Increase Zoom Out 75%33 Always Call SelectKoreaClientInfo() (Recommended)34 Enable /showname (Recommended)35 Read Data Folder First36 Read msgstringtable.txt (Recommended)37 Read questid2display.txt (Recommended)38 Remove Gravity Ads (Recommended)39 Remove Gravity Logo (Recommended)40 Restore Login Window (Recommended)41 Disable Nagle Algorithm (Recommended)44 Translate Client (Recommended)47 Use Ragnarok Icon48 Use Plain Text Descriptions (Recommended)49 Enable Multiple GRFs (Recommended)50 Skip License Sreen52 Use Custom Font53 Use Ascii on All Langtypes (Recommended)61 Disable Packet Encryption (Recommended)64 @ Bug Fix (Recommended)65 Load Custom lua file instead of iteminfo.lub67 Remove Quake skill effect68 Enable 64k Hairstyle69 Extend Npc Dialog Box73 Remove Hourly Announce (Recommended)204 Increase Attack Display74 Increase Screenshot Quality205 Enable Monster tables84 Remove Serial Display (Recommended)86 Only First Login Background88 Allow space in guild name90 Enable DNS Support (Recommended)97 Cancel to Login Window (Recommended)98 Disable dc_scream.txt99 Disable ba_frostjoke.txt102 Fix Tetra Vortex srccommonmmo.h #ifndef PACKETVER #define PACKETVER 20140205#endif // PACKETVER dataClientinfo.xml <?xml version="1.0" encoding="euc-kr" ?><clientinfo> <desc>Ragnarok Client Information</desc> <servicetype>korea</servicetype> <servertype>pk</servertype> <hideaccountlist /> <passwordencrypt /> <passwordencrypt2 /> <extendedslot /> <readfolder /> <connection> <display>AlphaRO</display> <desc>Version Alpha</desc> <balloon>ASD</balloon> <address>25.189.240.75</address> <port>6900</port> <version>20</version> <langtype>1</langtype> <registrationweb>https://www.google.com.ar/</registrationweb> <yellow> <admin>2000001</admin> <admin>2000002</admin> <admin>2000003</admin> </yellow> <loading> <image>loading00.jpg</image> <image>loading01.jpg</image> <image>loading02.jpg</image> <image>loading03.jpg</image> <image>loading04.jpg</image> <image>loading05.jpg</image> <image>loading06.jpg</image> <image>loading07.jpg</image> <image>loading08.jpg</image> <image>loading09.jpg</image> <image>loading10.jpg</image> </loading> </connection></clientinfo> Un poco más de Información: Usamos este cliente, actualizado (Que lo he leído por ahí, y me lo he bajado sólo para asegurarme que no sea eso. Encima se los obligué a bajar a is colegas). He probado con al menos 2 PC's distintas a la mía (Mañana serán 3). A mí, conectarme de local, me va perfecto. No he probado jugar con servicetype y langtype en el Clientinfo.xml, pero servertype no parece aceptar otra cosa que no sea pk (Y no sé porqué). También probé el quitar/poner la opción de DNS's en el Nemo, pero nada. Y no, no aparece ningún mensaje en los servidores en cuanto uno de mis amigos se quiere conectar. Y el error de ellos es "Failed to Connect" (O algo así) Puedo poner información de mis puertos también, pero... ¡Aún cerrados con Hamachi debería funcionar! (Que es lo último que probe. Por eso tiene esa IP) ¡Ayuda! Ya estoy muy quemado T_T
  9. ¡Wow! Probé con 2014-02-05b, y me funcionó perfecto. No tenía idea que fuera así, ni queme funcionara a la primera. Ahora, lo que no estoy muy seguro, es porque me funciona con ServerType en pk, y no en Sakray. Ahora me queda bastante por ver. Seguir "diffeando" (¿Se dice así, no?) el exe hasta que quede como me gusta (En vez de hacer que sólo funcione). Terminar de traducir la HUD y otras cosas. Buscarme un buen tuto sobre .grfs y ver si me puedo deshacer de la carpeta data, y algunas cosas más, como jugar con los .conf. Pero, qué se yo. No es nada en lo que necesite mucha ayuda (Aún. Es probable que vuelva a postear sobre estos temas XD) Respondiendo a tus respuestas (xD), sí, estaba al tanto que había algo que daba preferenca a la lectura de lua's sobre lub's (O al revez), lo mismo con la carpeta Data y los .grf. Del DATA.INI también sé que permite hasta 10 valores (0-9), que realmente no creo que necesite usar más, nunca (Bueno... eso pensaba yo de mi 2TB de espacio en disco cuando me compre el ordenador, y apenas me quedan unos GB's XD. Eso sí, muchas gracias. Me estaba volviendo loco. No paraba de mirar el map server, y creo que me centré mucho en eso. Voy a seguir experimentando un poco por mi cuenta, y ya os molestaré más con otras cosas EDIT: ¡OH!, Sísísísí, ¿Alguien sabe como sacar el boton de Cash Shop? ES HORRIBLE xD
  10. ¡Buenas a todos!. Llevo ya muchos años jugando muchos tipos de servidores de RO, y este es el primero que intento montar. Con la Base de Datos y el Compilador, no tuve prácticamente problemas; me doy buena maña con esto, y realmente no me gusta pedir mucha ayuda Ahora, en cuanto terminé de settear mi servidor, empezaron los problemas. Realmente no tuve la oportunidad de encontrarme un BUEN tutorial para configurar el cliente. La mayoría te dice qué usar, pero nadie te dice para qué sirven. Realmente, no tengo conocimiento previo alguno de cómo se organiza la carpeta del RO. Aún no tengo muy en claro que define el uso de los .lua y los .lub. No sé que es lo que define el que tenga que usar el clientinfo.xml, y tengo menos idea de cómo cambiarme la carpeta data por un .grf (Y ni siquiera sé si lo que haga en Data, me va a servir). Aunque, dejando un poquito mi curiosidad de lado, me gustaría resolver mi problema primero. Básicamente, me deja loguear con mi cuenta, e incluso crear personaje, pero cuando intento entar con este, me dropea. Hago un resumen de lo que tengo, e hice: Me baje el Hércules, modifiqué y compilé. Lo conecté con MySQL y configuré la base de datos. (Sí, p1/s1 están bien puestos) Testee el correr los tres servidores. Sin errores. Me baje el 2014-02-12aRagexe.exe. Modifiqué el PACKETVER mmo.h (20140212). Re-compilé. (Acá empieza lo complicado) Cree mi clientinfo. ServiceType es korea. ServerType es pk. (Por aguna razón, siendo sakray no pasa de la screen de login). (Y lo copie e hice un sclientinfo, que no sé qué define cual usa) Me baje el Nemo y el Loki. "Diffee" el Ragexe unas cuantas veces, hastaque funcionó bien. Me bajé el Client Translation Project. Me pase la carpeta Data y System (Incluso llegué a probar cambiarlos lua por lub). No sé muy bien que hacer con la kRO_lua. Seguí probando distintos perfiles del Nemo, hasta que me funcionó. (El Punto 5 y 6 los repetí mucho) Y ahí estoy. Encerrado desde algunos días. Sabiendo poco y sin ideas. Esta es mi primera opción. Si no, seguiré preguntando por el IRC o de ultima haré un post en la parte de inglés. Gracias desde ya.