Jump to content
  • 0
Keanu

[SOLVED] MariaDB Support

Question

Hi there,

 

I'm struggling to get Hercules running with MariaDB, i've seen the thread listing the changes made on github, have applied the changes manually (Not sure how else to do it, new to github!) but to no avail.

 

https://github.com/HerculesWS/Hercules/commit/e1e5bd338fe507d23ac72c964efa5c7009c30bba <-- That's what I used.

 

I'm still getting the error of: 

configure: error: MySQL not found or incompatible

Any help would be appreciated! Or if anyone could suggest a lower footprint rev of MySQL other than MariaDB, also appreciated!

 

Kind Regards,

-Keanu

Edited by Keanu

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Okay so after a lot of searching, and I mean a lot. I managed to find this on rAthean's forums.

./configure --enable-64bit --with-MYSQL_LIBS=/usr/lib64/libmysqlclient.so

I didn't have lib64, however had lib, so all I had to do was run

./configure --enable-64bit --with-MYSQL_LIBS=/usr/lib/libmysqlclient.so

And it compiled fine.

 

I'm not entirely sure if i'm allowed to post rAthena links in here, so I won't, however i'd like to tag on a massive shout out and thank you to " Latheesan " from the rAthena forums for this fix, and hopefully it'll help someone else out on the Herc Forums.

 

Please consider this topic closed.

 

Regards,

Share this post


Link to post
Share on other sites
  • 0

Anyone have any ideas? Still trying to fix this but stuck as the code isn't the same as what's listed on the fix. If anyone has any suggestions on a different database to use, that would be great? Also, please let me know if this is the wrong board for this. I feel it may fit better in support instead??

Share this post


Link to post
Share on other sites
  • 0

Hi Ridley,

 

First off, thanks for the reply! :)

 

I've tried with the "libmariadb-client-lgpl-dev", whenever I try the command "apt-get install libmariadb*" I get the following error: 

 

[email protected]:~# apt-get install libmariadb*
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libmariadb-client-lgpl-dev' for regex 'libmariadb*'
Note, selecting 'libmariadbclient16' for regex 'libmariadb*'
Note, selecting 'libmariadbclient18' for regex 'libmariadb*'
Note, selecting 'libmariadb2' for regex 'libmariadb*'
Note, selecting 'libmariadbclient-dev' for regex 'libmariadb*'
Note, selecting 'libmariadb-client-lgpl-dev-compat' for regex 'libmariadb*'
Note, selecting 'libmariadbd-dev' for regex 'libmariadb*'
Note, selecting 'libmariadbclient16-dev' for regex 'libmariadb*'
libmariadb-client-lgpl-dev is already the newest version.
libmariadb2 is already the newest version.
libmariadb2 set to manually installed.
libmariadbclient18 is already the newest version.
libmariadbclient18 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libmariadb-client-lgpl-dev-compat : Conflicts: libmysqlclient-dev
E: Unable to correct problems, you have held broken packages.

Google doesn't really help me with that issue, just a bunch of suggestions of different packages to install / try installing, all of which i've tried (been at this for about 6 days now!)

 

i've even tried "apt-get install mariadb-client-10.1 mariadb-client-core-10.1 mariadb-common mariadb-server-10.1 mariadb-server-core-10.1" etc etc... But to no avail.

 

All leads to;

checking for library containing backtrace... none required
checking for mysql_config... /usr/bin/mysql_config
checking for mysql_init... no
checking mysql.h usability... yes
checking mysql.h presence... yes
checking for mysql.h... yes
checking MySQL library (required)... no
configure: error: MySQL not found or incompatible

Kind Regards,

-Keanu

 

Also as a side note, Ridley, can you PM me when you're free for some work please! Thanks!

Edited by Keanu

Share this post


Link to post
Share on other sites
  • 0

@4144?

 

I never worked with MariaDB but from the logs it requried mysql to be installed too, and since it errors i'd say you didn't do that.

 

https://www.linode.com/docs/databases/mysql/how-to-install-mysql-on-centos-7

 

Hi Ridley,

 

Thanks again for the reply. Please correct me if i'm wrong, but MariaDB should just be a replacement, rather than running both itself and MySQL alongside. Also, it seems that when MariaDB is installed, you can't install "libmysqlclient-dev", or much else for that matter. (lol!) so i'm not entirely sure how i'd run them side by side!

 

Going by the link on my first post - https://github.com/HerculesWS/Hercules/commit/e1e5bd338fe507d23ac72c964efa5c7009c30bba it seemed there was a commit to add support for MariaDB, however due to the fact that it was released over 2 years ago, the code is different and I can't really seem to make heads or tails of it! I did try adding in as much of it as I could, however to no avail! (Especially in the configure.in) 

 

Thanks for your help so far!

 

Kind Regards,

-Keanu

Edited by Keanu

Share this post


Link to post
Share on other sites
  • 0

it seems that when MariaDB is installed, you can't install "libmysqlclient-dev", or much else for that matter. (lol!)

I believe you have to to install libmariadbclient instead.

Share this post


Link to post
Share on other sites
  • 0

 

it seems that when MariaDB is installed, you can't install "libmysqlclient-dev", or much else for that matter. (lol!)

I believe you have to to install libmariadbclient instead.

 

Hi Secrets,

 

Thanks for the suggestion. I'm unable to find libmariadbclient, however i've found libmariadbclient-dev. I'm pretty sure I did try this before, however will update in a second...

 

Andddd. Sadly no luck!

checking MySQL library (required)... no
configure: error: MySQL not found or incompatible

 

Thank you for the suggestion though!

 

Kind Regards,

-Keanu

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.