Jump to content
4144

Another Nemo patcher fork

Recommended Posts

On 17/12/2018 at 9:59 PM, Roxas18 said:

Hi, just wondering does anyone know how to make that 2018 client read encrypted grfs? i'm using 2018 05 30...

Regards

thats the job from a .dll that the encryption software gives you.. the actual patch you need to use is something to enable it to use 3rd party dlls I dont quite remember the name maybe its: UseCustomDLL

Share this post


Link to post
Share on other sites

@4144

I prepared the patch which changes the type of time displaying by which the character deletion is delayed.

It works for 2018 EXE versions. You can add it to your fork. Thanks

https://mega.nz/#!cVtw3C6R!FMyyHx-CCwkjWL6s-zB2a1EFBsxu9bfIj2-GEtZy3fI

Before: it shows the date and time when the player will be able to delete character.
After: it shows the remaining time when the player will be able to delete character.

DnH13kN.png >>>>>>>>>>ONcqSpC.png

 

Share this post


Link to post
Share on other sites

i think this is server issue with time, but as temp workaround nemo patch can be ok too

thanks

 

Share this post


Link to post
Share on other sites
23 minutes ago, 4144 said:

i think this is server issue with time

It isn't the issue. EXE without patch shows date. EXE with patch shows remaining time in hours, minutes, seconds.

For example: now + 24 hours

EXE without patch will show: 31 December, 1 hour 2 minutes 30 seconds

EXE with patch will show: 24 hours 0 minute 0 second

You will not be able to do the same result on server side only.

https://rathena.org/board/topic/117636-client-deletion-details/

Edited by Functor

Share this post


Link to post
Share on other sites

yes i undestand. i mean people reported what this date completely broken, but it really can be fixed in server side.

But different options is good

Will push into nemo after nemo site pipeline will complete.

Share this post


Link to post
Share on other sites

I didn't know about the issue of Hercules. Can you show me these reports? I couldn't find open issues which are connected with it.

Because as I understand:

If server sends the correct amount of seconds to the end of delay - EXE will show correct info in both cases. With and without my patch. But in the different formats.

If server sends the incorrect amount of seconds to the end of delay - EXE will show incorrect info in both cases. With and without my patch. But in the different formats.

So, it is interesting, how my patch can help with the bug of server-side code.

Share this post


Link to post
Share on other sites

Some one want translate nemo to own language?

From old nemo features exists translations for some strings only, but now possible translate almost all texts.

For basic strings need open UI_LANGUAGE.ini (for example UI_Russian.ini) and translate strings after = to own language

For patches types, messages etc need open Patches_LANGUAGE.ini (for example Patches_Russian.ini) and translate strings after = to own language.

If need for language, nemo can display text in left to right or right to left.

Share this post


Link to post
Share on other sites

probably you forgot patch "Copy cheat defender" or copy cdclient.dll from nemo manually to your client dir?

Share this post


Link to post
Share on other sites
40 minutes ago, 4144 said:

probably you forgot patch "Copy cheat defender" or copy cdclient.dll from nemo manually to your client dir?

Client kRO 2019-01-16

Quote

my clientinfo.xml

<?xml version="1.0" encoding="euc-kr" ?>
<clientinfo>
    <desc>Ragnarok Client Information</desc>
    <servicetype>brazil</servicetype>
    <servertype>primary</servertype>
    <connection>
        <display>Servidor de Acesso Gratuito</display>
              <address>25.44.194.105</address>
              <port>6900</port>
              <langtype>12</langtype>
        <registrationweb>www.ragnarok.com</registrationweb>
        <loading>
            <image>loading00.jpg</image>
            <image>loading01.jpg</image>
            <image>loading02.jpg</image>
            <image>loading03.jpg</image>
            <image>loading04.jpg</image>
            <image>loading05.jpg</image>
        </loading>
       </connection>
</clientinfo>

 

2019-01-16cRagexe patch using nemo recommended

screen001.jpg

screen000.jpg

Share this post


Link to post
Share on other sites

You can answer in my previous question? do you copy cdclient.dll?

If not client will not works.

Share this post


Link to post
Share on other sites
26 minutes ago, 4144 said:

Você pode responder na minha pergunta anterior? você copia cdclient.dll?

Se não o cliente não funcionará.

yes, it still does not work.

Edited by zeffen159

Share this post


Link to post
Share on other sites
On 1/23/2019 at 11:25 PM, zeffen159 said:

I did not understand

He asked which commit hash do you used for that particular case scenario and use this command inside your Hercules emulator folder to check latest commit hash.

git rev-parse --short HEAD

 

Share this post


Link to post
Share on other sites

@4144, I tried to configure with an option of "--enable-packetver-main" just like stated on your website however the option does not exist on the configure file at all. Does it still affect the behavior of Hercules server in some way? .... For example (i.e 2019-01-23dRagexe)

Share this post


Link to post
Share on other sites

yes this is fine, option not exists, but i thinked it exists. I not removing it from site because think probably better add it to herc.

Other than --enable-packetver-main change server behavior.

Also rember what 2019-02-13 (main and re) may not work yet in herc and not works in nemo.

Share this post


Link to post
Share on other sites
26 minutes ago, 4144 said:

Nemo updated

New patch "Fix Homunculus attack AI" by jchcc

Fixed some patches for clients 2019-02-13

Changelog

What is that for?

 

Share this post


Link to post
Share on other sites

homun attack ai? from some 2017 clients and newer, homunculus cant auto attack. need manually set targets.

this patch enable old auto attack way

Share this post


Link to post
Share on other sites
4 hours ago, AnnieRuru said:

So the Old AI works again?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.