Jump to content
anacondaq

Ragnarok Offline Newbie Pack 2021 | Make your RO server in less then 5 minutes

Recommended Posts

YOU CHANGED MY LIFE

 

If only i could get rid of this god awful character selection screen and these terribly obnoxious buttons

Lol it also killed some of my custom skills :(

Edited by lllaaazzz

Share this post


Link to post
Share on other sites
10 hours ago, uekifan said:

Hello! Sorry I have a question, this always appears when I run run-serv.bat "map serv.exe does nto exist make sure you compiled your server"

You just have to compile your server before you run it.

Share this post


Link to post
Share on other sites

Great job. But there are some bugs. My chars can't  enter back part of Criatura Academy, behind the receptionist's table. And when chars enter the right room on the second floor of academy, they absolutely can't move.

Share this post


Link to post
Share on other sites

And a little question. A monster behaviour and stats are differ from last official server I have played (euRO R.I.P.). Where is the best and most corresponding with kRO db, for correcting mistakes in mob_db.conf (and maybe in mob_skill_db.conf)? iRO Wiki or ratemyserver or maybe anything else?

P.S. Maybe troubles are not with mob_db. Maybe wrong damage formula is applied? I have very low dmg from monsters. For example, Orc Warrior deals me (low-lvl archer) near 30 dmg.

Edited by Altair86

Share this post


Link to post
Share on other sites

So I've recently moved to try using this instead of your previous rAthena release (because you're obviously not supporting that one any more, and I think most of my work can transfer over to this), but in both cases I've run into the same issue; OpenServer refuses to run, and currently doesn't produce very helpful logs. I just get the following:

2019-08-21 00:28:16  --------------------------------------------
2019-08-21 00:28:16  Start server start-up procedure
2019-08-21 00:28:16  Creating a virtual disk
2019-08-21 00:28:16  Updating configuration MySQL-5.6
2019-08-21 00:28:16  Updating configuration of Sendmail
2019-08-21 00:28:16  Updating configuration PHP-7.0
2019-08-21 00:28:16  Updating configuration PHPMyAdmin
2019-08-21 00:28:16  Updating configuration Nginx-1.12
2019-08-21 00:28:16  Launch MySQL-5.6
2019-08-21 00:28:16  Launch PHP-7.0
2019-08-21 00:28:17  Launch Nginx-1.12
2019-08-21 00:28:17  Checking server status
2019-08-21 00:28:56  Failed to start Nginx-1.12
2019-08-21 00:28:56  Failed to start MySQL-5.6
2019-08-21 00:28:56  Failed to start!
2019-08-21 00:28:57  --------------------------------------------
2019-08-21 00:28:57  Beginning of procedure to stop server
2019-08-21 00:28:57  Stopping system modules
2019-08-21 00:28:57  Turning off a virtual drive
2019-08-21 00:28:57  Server has successfully stopped in 0.547 seconds!

MySQL logs reveal the following:

error: Found option without preceding group in config file: w:\modules\database\MySQL-5.6\my.ini at line: 1
Fatal error in defaults handling. Program aborted

And running OpenServer in debug mode gives me the following for nginx, one of the things that's apparently failing to start:

w:\modules\http\Nginx-1.12>"w:\modules\http\Nginx-1.12\nginx.exe" -c "w:\modules\http\Nginx-1.12\conf\nginx.conf"
nginx: [alert] could not open error log file: CreateFile() "logs/error.log" failed (3: The system cannot find the path s
pecified)
2019/08/21 00:44:15 [emerg] 17212#10476: unknown directive " #" in w:\modules\http\Nginx-1.12\conf\nginx.conf:9

w:\modules\http\Nginx-1.12>PAUSE
Press any key to continue . . .

But neither really tell me what's going wrong. The only setting I've changed in OpenServer is to run it in debug mode, to get the above, and I have installed the extra files to try using if it didn't run (just in case, to check if that was the issue; it DOES start, but doesn't get anywhere).

Do you (or anyone, really) have any idea what might be causing this? The rAthena version of this project ran fine last time I played with it, which was around four months ago. I did for a time have a shared folder on a NAS device mapped to W, but noticing the possible conflict removed the mapped drive. It still hasn't worked and I'm running out of things to temporarily disable to see if it's the issue.

Share this post


Link to post
Share on other sites

There is no Lasagna and Rock Ridge sailors in Izlude & Alberta. Only labels above empty places. When I created a cat char, he appears on island with sunken ship, near Izlude. And he needs a lot of porings for 1% of 1st  job lvl. Maybe job exp chart for summoners is broken.

 

Edited by Altair86

Share this post


Link to post
Share on other sites
On 8/19/2019 at 7:23 PM, Altair86 said:

Great job. But there are some bugs. My chars can't  enter back part of Criatura Academy, behind the receptionist's table. And when chars enter the right room on the second floor of academy, they absolutely can't move.

Please, next time add /where the output (enter the command to the chat) to display where are you now. Because without a map and coordinates of the map where you stand, it's very hard to understand the problem that you said. 

On 8/20/2019 at 7:39 PM, Altair86 said:

And a little question. A monster behaviour and stats are differ from last official server I have played (euRO R.I.P.). Where is the best and most corresponding with kRO db, for correcting mistakes in mob_db.conf (and maybe in mob_skill_db.conf)? iRO Wiki or ratemyserver or maybe anything else?

https://www.divine-pride.net/ and irowiki

On 8/21/2019 at 8:36 PM, Altair86 said:

There is no Lasagna and Rock Ridge sailors in Izlude & Alberta. Only labels above empty places. When I created a cat char, he appears on island with sunken ship, near Izlude. And he needs a lot of porings for 1% of 1st  job lvl. Maybe job exp chart for summoners is broken.

 

Confirm, I did not know it earlier. I hope the admins will implement so important parts of the episode soon.

On 8/22/2019 at 7:28 AM, toleedan said:

guys, where u guys get newer patch? in this patch, illusion equipment still not implemented.. and the dungeon still have no monster there.. can you guys help me?

Which dungeon? Tell me the map or better give a link. Yes, some content is luck here, but I hope with a time everything missing will be added. As I see not too much missing, I can't promise, but maybe someday when I have really free time, I can dig in and implement missing parts if someone will not do it before me. 

On 8/21/2019 at 3:18 AM, Feldherren said:

Do you (or anyone, really) have any idea what might be causing this?

In settings try to change webserver port from 80 to 91, from 443 to 447, and try again. Also, you can change what to load, and change nginx to apache for example. Also, you need to install process hacker and check, maybe some app bound to a port what used by a OpenServer (3306, 80, 443)

Share this post


Link to post
Share on other sites

anacondaq, thank you for answer.

OK, I describe  problems more exactly.

Maps

Criatura Academy F1 (iz_ac01): 91, 44. I can't move to (91,45). Cells are marked as walkable (they are green-square highlighted under cursor).

I found a method to move the back part of the academy: if I pass between two tables, I can do it. But moving in this location seems as an "invisible labyrinth".

Criatura Academy F2 104,27 (right portal upstairs). I am entering the portal, appearing on the 2nd floor and can't move. If I left the game and login again, i appear in the room on the F2 near 66,168. And I can walking in the room, but can't left the room. In the thief trainer room is same situation: I can't left the room (can't go from line x=83 to line x =84). (iz_ac_02) 83, 138, for example - can't move 84, 138.

Prontara near 140,60, has an "invisible labyrinth" too. There is wide space between houses, cells seems walkable, but I can't pass through.

Monster Attack problems.

For example, Orc Warrior. THe file monster_db_conf says: Attack: [71, 33]. As I understand, it means attack between 71 and (71+33). Irowiki says 71-104, OK. Divine-Pride says 132 - 161 . Hmm. On EuRO damage from orcs was 100+. Iro differs from EuRo or irowiki lies? UPD: irowiki lies, on iRO orcs inflict 100+dmg.

And when I set Attack to [71, 0],damage still has variance. With 8 vitdef my character receives ~50-70 dmg. It is strange.

Monster Behaviour.

Non-assist Hornets and non-aggressive Familiars. Maybe it is a bug, maybe feature of latest Korean patches, I don't know.

 

Edited by Altair86

Share this post


Link to post
Share on other sites

Is any way exists to obtain real data about monster stats on iRO(the only official server that is accessible for me)? Data from irowiki and from divine-pride are different.

Share this post


Link to post
Share on other sites

On athena version, real mob dmg is same with iRo (tested on porings and lunatics, on hercules they were really weaker). But renewal attack values in mob_db.txt are the same with hercules values in mob_db.conf. How may it be? Lunatic deals ~20 dmg to novice on iro & athena, but ~10 on herc.

Share this post


Link to post
Share on other sites

for stats you should check only kRO because hercules follow only it

Share this post


Link to post
Share on other sites

A strange thing. I created second account and successfully connected to the game from second computer. But my characters from different accounts can't see each other O_o Every player has his own copy of the world (but they can send messages to each other). Can this problem be solved? Or it's a feature of this project?

UPD: The problem is solved, It's a feature of Izlude and a map under Prontera. At Prontera we can see each other.

Great Anacondaq and other developers are great too!!! I can play Ragnarok with my wife !

Edited by Altair86

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.