Jump to content
anacondaq

Ragnarok Offline Newbie Pack 2021 | Make your RO server in less then 5 minutes

Recommended Posts

Openserver not running - cannot go green

I checked the logs, this is what it gave me

 

[Sun May 09 22:48:56.580861 2021] [ssl:warn] [pid 28464:tid 568] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:56.722482 2021] [ssl:warn] [pid 28464:tid 568] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:57.593773 2021] [mpm_winnt:notice] [pid 28464:tid 568] AH00455: Apache/2.4.41 (Win64) OpenSSL/1.0.2s configured -- resuming normal operations
[Sun May 09 22:48:57.593773 2021] [mpm_winnt:notice] [pid 28464:tid 568] AH00456: Apache Lounge VC14 Server built: Aug 12 2019 10:48:01
[Sun May 09 22:48:57.593773 2021] [core:notice] [pid 28464:tid 568] AH00094: Command line: 'W:\\modules\\http\\Apache_2.4-PHP_7.0-7.1\\bin\\httpd.exe -d W:/modules/http/Apache_2.4-PHP_7.0-7.1 -f w:\\modules\\http\\Apache_2.4-PHP_7.0-7.1\\conf\\httpd.conf'
[Sun May 09 22:48:57.598656 2021] [mpm_winnt:notice] [pid 28464:tid 568] AH00418: Parent: Created child process 33508
[Sun May 09 22:48:58.284915 2021] [ssl:warn] [pid 33508:tid 460] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:58.425223 2021] [ssl:warn] [pid 33508:tid 460] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:58.468764 2021] [mpm_winnt:notice] [pid 33508:tid 460] AH00354: Child: Starting 150 worker threads.
 

Not sure what to do,

Share this post


Link to post
Share on other sites
5 hours ago, zagnos said:

I talked to this Stylist NPC in Prontera and I was shuffling through hairstyles, then it suddenly crashes. I get errors about missing sprite file or something. Now I cant even log back in, as soon as I do, same thing happens because the character is there with a hairstyle that does not exist.

 

After hours of googling I figured I need to edit SQL to change it back or delete the char, which I dont know how. So instead I wanted to add another admin account but:

 

I cant access PHPMYADMIN. I get this error:

 

mysqli::real_connect(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: NO)

 

any ideas?

1.png

This is client-side issue ng SQL. check the root folder based on the error and see if the .spr file is actually there.

For accessing the SQL user is root and just leave the password blank.

2 hours ago, padfoota said:

Openserver not running - cannot go green

I checked the logs, this is what it gave me

 

[Sun May 09 22:48:56.580861 2021] [ssl:warn] [pid 28464:tid 568] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:56.722482 2021] [ssl:warn] [pid 28464:tid 568] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:57.593773 2021] [mpm_winnt:notice] [pid 28464:tid 568] AH00455: Apache/2.4.41 (Win64) OpenSSL/1.0.2s configured -- resuming normal operations
[Sun May 09 22:48:57.593773 2021] [mpm_winnt:notice] [pid 28464:tid 568] AH00456: Apache Lounge VC14 Server built: Aug 12 2019 10:48:01
[Sun May 09 22:48:57.593773 2021] [core:notice] [pid 28464:tid 568] AH00094: Command line: 'W:\\modules\\http\\Apache_2.4-PHP_7.0-7.1\\bin\\httpd.exe -d W:/modules/http/Apache_2.4-PHP_7.0-7.1 -f w:\\modules\\http\\Apache_2.4-PHP_7.0-7.1\\conf\\httpd.conf'
[Sun May 09 22:48:57.598656 2021] [mpm_winnt:notice] [pid 28464:tid 568] AH00418: Parent: Created child process 33508
[Sun May 09 22:48:58.284915 2021] [ssl:warn] [pid 33508:tid 460] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:58.425223 2021] [ssl:warn] [pid 33508:tid 460] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Sun May 09 22:48:58.468764 2021] [mpm_winnt:notice] [pid 33508:tid 460] AH00354: Child: Starting 150 worker threads.
 

Not sure what to do,

Could be an error while installing? see which version is compatible with you. Is this x64 or x86?

11 hours ago, jejebuks said:

hello admins,support.

I am thankful for the RO offline package

I do have some issues and I attached in an image.

most illusion instance based items seems to be place in etc tab in inventory.

Please help me resolve.

TYVM

vOS.jpg

Find that item in the item_db.conf
Change from Type: 3 to Type: 4

On 4/23/2021 at 5:53 AM, Nakano15 said:

The issue of not being able to open the skill window literally locked the game to me. I'm bound to be a novice forever this way lol.

Also, Pre-Renewal Izlude still has pathing problems.

Download the latest kro translation.

On 1/9/2021 at 7:21 AM, kecapbabi69 said:

Hello friends,

 

Thank you @anacondaq for this wonderful tutorial installation for Ragnarok Offline Renewal based. I've tried to play inside the admin account it's fun to play as admin. But may i know how to change my job from ex. Rune knight to job Game Master or Administrator. I mean I wanna try to use GM of sprite lol. And how to have all job skill at one administrator character? Whats the commands? Hahaha Thank you very much for who help me! Happy new year!

For this you need to use NEMO patch to apply your character as a GM sprite.

Share this post


Link to post
Share on other sites
Posted (edited)

@Promeister

"Could be an error while installing? see which version is compatible with you. Is this x64 or x86?"

 

Does the new Openserver included in the package require installation? I didn't see x64/x86 like the old packs. The new pack seems to only have one exe now.

 

My old packs still work for sure

Edited by padfoota

Share this post


Link to post
Share on other sites
13 hours ago, Promeister said:


For accessing the SQL user is root and just leave the password blank.

 

thanks for reply. but as I said leaving password blank didnt work. while trying to learn how to set up mySQL though, I accidently found out in a file that the password is also "root". with that I was able to login and change character hair from there

Share this post


Link to post
Share on other sites

I downloaded the files but folder Clean_RO_Client is not in the package. 

 

Also, I followed the steps in the readme.txt in the package and got the Log in screen but it isn't in english. Is it possible to get it in english??

Share this post


Link to post
Share on other sites
9 hours ago, jejebuks said:

i can't see them in item.db

vOS2.jpg

Add them like this:

{
    Id: 18180
    AegisName: "AC_B44_OS"
    Name: "AC_B44_OS"
    Type: 3
},

Share this post


Link to post
Share on other sites
1 hour ago, Promeister said:

Add them like this:

{
    Id: 18180
    AegisName: "AC_B44_OS"
    Name: "AC_B44_OS"
    Type: 3
},

thx Promeister but unfortunately it did't work.

i am trying to look for its script and this is all  Igot.

how can I convert to hercules item_db script,

vOS3.jpg

Share this post


Link to post
Share on other sites
On 5/5/2021 at 9:18 PM, Granini said:

Hello,

 

I tried to set this up for me but i get an error that i can not connect. char and login server gives me two diffrent infos. Once it tells me that it can not find the exe, but i checked and both are in the file.

And sometimes, it tells me to change somethig in the conf.

 

I have no real experience with all of that. I did everything as told in the readme, did it now 3 times, delete everything, set up everything as told by the readme and thread but always the same problem.

 

Hope someone can help me :(

 

 

Error RO.PNG

Error 2 RO.PNG

I still was not able to get it to run. Can someone help me please?

Share this post


Link to post
Share on other sites
Posted (edited)

Good day, I found an error involving the Rebellion class, its base level stuck to 99 and all its skills always miss.  Is there a way to fix this?

I'm using herc renewal, no problems for other classes.

 

edit: I hope this helps but, after some tweaking with exp_group_db.conf I found out that emulator seems to not recognize rebel as an extended class, but instead recognizes the Rebel class as one of the Firstclasses.

 

 

02.jpg

01.jpg

Edited by godgiven25

Share this post


Link to post
Share on other sites

i don't know how to edit things, i have zero experience with this kinda of stuff, i don't know how to change death penalty (every time i die i want to return to 0% xp of my current lvl), or raise the number of character slots, i'm also having the alt+s crash, i'm playing pre ren. but i copied the renewal files on my client, like someone told here, it work for the alt S crash, but the item descriptions are wrong.

 

if someone could help me, i would be very thankful 

Share this post


Link to post
Share on other sites

Hi guys,

 

On the newest update, I noticed the 02_client folder no longer has a data folder with a sclientinfo.xml. Is this intentional?

Share this post


Link to post
Share on other sites
Posted (edited)

Does anyone have these sprites?

I'm using this client and it has this error.

2021-06-29 07_42_18-Error.png

 

Edited by johnlincon

Share this post


Link to post
Share on other sites

Hello,

 

Many thanks for your job,

 

 

Everything work fine and stable, but login/char/map servers show the following:

[info] pinging sql server to keep connection alive site

 

Twice per minute.

 

Is it possible to swith these notes off?

Or it might be some kind of error? 

ping.jpg

Share this post


Link to post
Share on other sites
22 hours ago, johnlincon said:

Does anyone have these sprites?

I'm using this client and it has this error.

2021-06-29 07_42_18-Error.png

 

To solve this problem on the client. Put these files inside your GRF.
 

Inside the correct folder of course.

summoner.zip

13 hours ago, Timokha said:

Olá,

 

Muito obrigado pelo seu trabalho,

 

 

Tudo funciona bem e estável, mas os servidores login / char / map mostram o seguinte:

[info] ping do servidor sql para manter a conexão do site ativa

 

Duas vezes por minuto.

 

É possível desligar essas notas?

Ou pode ser algum tipo de erro? 

ping.jpg

\conf\global\console.conf

 

In this file you can edit your console.


 

Share this post


Link to post
Share on other sites
On 6/30/2021 at 12:59 PM, johnlincon said:

\conf\global\console.conf

In this file you can edit your console.


 

Hello,

 

Thanks, 

 

Is there a way to hide only these messages "pinging sql server to keep connection alive site"?

If I put "1" in console.conf it hides all INFO messages, including messages which I must receive. 

Share this post


Link to post
Share on other sites
14 hours ago, Timokha said:

Hello,

 

Thanks, 

 

Is there a way to hide only these messages "pinging sql server to keep connection alive site"?

If I put "1" in console.conf it hides all INFO messages, including messages which I must receive. 

In this case, it would be via \src\common\console.c

but for this file is more complicated

Share this post


Link to post
Share on other sites
7 hours ago, johnlincon said:

In this case, it would be via \src\common\console.c

but for this file is more complicated

Found needed line in \src\common\\sql.c, works, thanks.

Share this post


Link to post
Share on other sites

Hello!

 

Why I can't access to PhpMyAdmin? After insert user ID (root) then I click enter wihout inserting any password as per instructions. But access denied

Capture.PNG

Share this post


Link to post
Share on other sites
3 hours ago, vilkhl said:

Hello!

 

Why I can't access to PhpMyAdmin? After insert user ID (root) then I click enter wihout inserting any password as per instructions. But access denied

Capture.PNG

Password: root

Share this post


Link to post
Share on other sites

Finally was able to make it run. Is there a way to add player bots? Bots you can invide and fight with you, open up shops and / or buy stuff from your shop you open etc?

 

Also is there a way as Admin to add levels and get into a kind of God mode? So i can explore the world as i wish? I was never able to do so in my childhood and i would love to visit places that are ment for many other people.

 

But with only me on this "server" i cant play most content.

Share this post


Link to post
Share on other sites

Hello,

 

I've set up a Hercules up-to-date server on my homeserver, and I see both in other guides and in this thread mentions of editing sclientinfo.xml (or clientinfo.xml) in the data folder.  Using the clean client and post-renewal for_client packages, there IS NO data folder or sclient.xml to edit.  How would I go about changing the target server with the current packages available from OP?

Edited by cas13f
correction

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.