Ragnarok Offline Pack 2019 | Make your RO server in less then 5 minutes

Recommended Posts


Current Version: 18 August 2019
Hercules Hash:

Download Links (~4GB):

Optional, full clean kRO game client (20190818): DOWNLOAD 2.9GB


TL;DR: If you're a newbie, and want to launch a Hercules emulator and try it in 5 mins, just download everything here, extract, run OpenServer, Copy client files to kRO folder, run emulator, run client, login and play or do whatever you want to do. This pack already pre-configured and compiled, you need not do anything here, just download, extract, run.

What is that?

This is a newbie package that contains 1 click solution for launching hercules emulator in a single click.
This package only for education. Do not use this package anywhere in production.

This package good demonstration of how everything should be configured by yourself to make it work.
We can find here a good guide on how to configure everything by yourself:

What inside the package?


You have 7 folders:

  • 01_emulator = here emulators (pre-compiled and pre-configured) for RENEWAL or classic PRERE mechanics
  • 02_client_side = here is your client-side what need to copy-paste to your clean kRO client
  • 03_openserver = here is Open Server (mysql server where stored your game database and which required by the emulator)
  • 04_useful_tools = here are different useful tools what you usually will need when will work with the emulator or databases
  • 05_misc_repos = here are repositories from which it has built the client-side, and exe patched.
  • 06_cmder = this is tool will be good for you to update emulator to latest version (and other files in misc_repos)
  • 07_clean_kRO_client = this is clean kRO client (2018 somewhere in march updated), need for you to run your own RO copy.

How to use all of this?

  1. extract files inside 01_emulator, 02_client_side, 03_openserver, 07_clean_kRO_client
  2. Now, what emulator version do you need? Latest (current official servers) (renewal mechanic (suras, dorams, etc classes)) or classic PRE-re (champion, high wizard, high priest)?
  3. Now if for example, you use PRERE mechanic (where is high wizard class, paladin, lord knights, and no 3rd classes) your steps is next:
  • a.) go to 02_client_side\FOR_PRERE_EMULATOR\
  • b.) select all files in this folder (FOR_PRERE_EMULATOR) and copy (CTLR+C)
  • c.) now go to 07_clean_kRO_client/clean_kRO_client/ folder and copy files here (overwrite if windows explorer will ask to do that).
  • d.) now you need to run OpenServer (it's a server which stores all your player's data inside the database, required by the emulator) and run it.
  • e.) Click on Red Flag -> Run the server, make sure in your tray you got Green Flag.
  • f.) Now go to 01_emulator\hercules_PRERE\ and run: run-server.bat
  • g.) Now go to your 07_clean_kRO_client/clean_kRO_client/ and run: 2018-04-18bRagexeRE_patched.exe

Your emulator, your database, and the client are running. Now you can try to login into the game.

About Accounts:



I already made for your 2 accounts (with administrator privileges, and just simple player)

login: admin
pass: 123456

login: player
pass: 123456

If you want to add an extra account (create a new one).
Open game client, in LogOn field, enters your login for your account what you want to register.
Then, after login name add _M (for male account sex) or _F (for female account sex)
And in password field enter your password what you want to have on this account.
Now press enter, and it will create your account.

In other words:
LogOn field:
Login: myuser_M
pass: mypassword

If you will do it. You will create an account `myuser` with password: `mypassword`.
Simple, is not it? You need none control panel for registration, it will work like that.


How to make a GM account or how access database?

For that, you need to click on Green Flag -> Advanced -> PHPMYADMIN
In the login field of phpmyadmin enter: "root", in the password field enter nothing. (no password)
Press enter or login, and you will be in the database.

Databases well structured, so mostly always you need not edit too much there.


How to make a GM account?

You opened PHPMYADMIN.
Now select your database, and find in this database table called: "login"
Open this table, and find your account name, and you will see column "group_id".
Edit number in this column (group_id) to 99.
0-99 = your GM level. 99 = super admin with all privilegies, 0 = simple player with no privieleges.

Okay, everything working for me, what can I do next?

  1. My short answer:
  2. Read all topics, read different guides, read info about NPCs
  3. Read info how to add NPCs, how to enable them, how to disable them
  4. Read /doc/ folder files inside your emulator folder
  5. Read wiki pages:

Do experiments and do not afraid to destroy everything or remove them.
Just do mistakes and errors, it's how people learning something new, though mistakes.

DO not afraid to do a lot of mistakes and ask questions.
People will help you if you will try to help yourself first and will make good questions with some research before posting messages.

What tools can I use for making everything much easier for me?

Tools what you MUST have:

  • - Grf Editor
  • - Server Database Editor
  • - VSCode / Notepad++ / Sublime Text / Atom  (any of these editors and select always C syntax highlight for opened files)

I want to play with my friends on my server

The solution that you will find by the link below is a terrible solution.
But usable for a small group of people who for education only want to launch their server ONLINE (for others).
This is SUPER bad, and never do that, (it's weird, after the only time you will understand why).
But if you still asking here is the link:

I want make a donation as a gesture of goodwill:

Ask administrators here:
If they accept donations or not, I found none donation link.

Optionally you can always support next guys:

  • 4144 for massive help to the current RO scene at all by his hard work.
  • AnnieRuru for a lot of scripts, helping newbies on the forums
  • - all these guys
  • zackdreaver for a lot of efforts on a translation project
  • and to all guys, scripters, mappers, etc players who spend their time, their efforts just for you to make everything free what you see here.

Sorry if I didn’t mention someone.


I need help with <something>

There are a lot of talented developers, software developers, scripters, mappers, spriters, and many other people in this community.

Check the link:

Also, I accept all questions related to the basic newbie stuff on the topic.
Do not hesitate to ask even super stupid questions.
But before asking something, try to do a very simple thing: 

  1. Open google, in the search bar enter: ""
  2. Then write your question or problem
  3. Hit enter and check all links that you see, maybe someone already solved your problem earlier.



Edited by anacondaq
new update.

Share this post

Link to post
Share on other sites



If only i could get rid of this god awful character selection screen and these terribly obnoxious buttons

Lol it also killed some of my custom skills :(

Edited by lllaaazzz

Share this post

Link to post
Share on other sites
10 hours ago, uekifan said:

Hello! Sorry I have a question, this always appears when I run run-serv.bat "map serv.exe does nto exist make sure you compiled your server"

You just have to compile your server before you run it.

Share this post

Link to post
Share on other sites

And a little question. A monster behaviour and stats are differ from last official server I have played (euRO R.I.P.). Where is the best and most corresponding with kRO db, for correcting mistakes in mob_db.conf (and maybe in mob_skill_db.conf)? iRO Wiki or ratemyserver or maybe anything else?

P.S. Maybe troubles are not with mob_db. Maybe wrong damage formula is applied? I have very low dmg from monsters. For example, Orc Warrior deals me (low-lvl archer) near 30 dmg.

Edited by Altair86

Share this post

Link to post
Share on other sites

So I've recently moved to try using this instead of your previous rAthena release (because you're obviously not supporting that one any more, and I think most of my work can transfer over to this), but in both cases I've run into the same issue; OpenServer refuses to run, and currently doesn't produce very helpful logs. I just get the following:

2019-08-21 00:28:16  --------------------------------------------
2019-08-21 00:28:16  Start server start-up procedure
2019-08-21 00:28:16  Creating a virtual disk
2019-08-21 00:28:16  Updating configuration MySQL-5.6
2019-08-21 00:28:16  Updating configuration of Sendmail
2019-08-21 00:28:16  Updating configuration PHP-7.0
2019-08-21 00:28:16  Updating configuration PHPMyAdmin
2019-08-21 00:28:16  Updating configuration Nginx-1.12
2019-08-21 00:28:16  Launch MySQL-5.6
2019-08-21 00:28:16  Launch PHP-7.0
2019-08-21 00:28:17  Launch Nginx-1.12
2019-08-21 00:28:17  Checking server status
2019-08-21 00:28:56  Failed to start Nginx-1.12
2019-08-21 00:28:56  Failed to start MySQL-5.6
2019-08-21 00:28:56  Failed to start!
2019-08-21 00:28:57  --------------------------------------------
2019-08-21 00:28:57  Beginning of procedure to stop server
2019-08-21 00:28:57  Stopping system modules
2019-08-21 00:28:57  Turning off a virtual drive
2019-08-21 00:28:57  Server has successfully stopped in 0.547 seconds!

MySQL logs reveal the following:

error: Found option without preceding group in config file: w:\modules\database\MySQL-5.6\my.ini at line: 1
Fatal error in defaults handling. Program aborted

And running OpenServer in debug mode gives me the following for nginx, one of the things that's apparently failing to start:

w:\modules\http\Nginx-1.12>"w:\modules\http\Nginx-1.12\nginx.exe" -c "w:\modules\http\Nginx-1.12\conf\nginx.conf"
nginx: [alert] could not open error log file: CreateFile() "logs/error.log" failed (3: The system cannot find the path s
2019/08/21 00:44:15 [emerg] 17212#10476: unknown directive " #" in w:\modules\http\Nginx-1.12\conf\nginx.conf:9

Press any key to continue . . .

But neither really tell me what's going wrong. The only setting I've changed in OpenServer is to run it in debug mode, to get the above, and I have installed the extra files to try using if it didn't run (just in case, to check if that was the issue; it DOES start, but doesn't get anywhere).

Do you (or anyone, really) have any idea what might be causing this? The rAthena version of this project ran fine last time I played with it, which was around four months ago. I did for a time have a shared folder on a NAS device mapped to W, but noticing the possible conflict removed the mapped drive. It still hasn't worked and I'm running out of things to temporarily disable to see if it's the issue.

Share this post

Link to post
Share on other sites

There is no Lasagna and Rock Ridge sailors in Izlude & Alberta. Only labels above empty places. When I created a cat char, he appears on island with sunken ship, near Izlude. And he needs a lot of porings for 1% of 1st  job lvl. Maybe job exp chart for summoners is broken.


Edited by Altair86

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.