Jump to content
  • 0
Sign in to follow this  
Mushroom

Russian language in RO Zero client

Question

Hello,

 

I've faced a problem with using russian language in RO Zero.

As soon as I switch to russian and start typing - I can observer that I'm typing in korean

 

I'm using 2018-12-19a zero client. 

Hexed with following settings:
 

9 Disable 1rag1 type parameters (Recommended)
23 Enable /who command (Recommended)
24 Fix Camera Angles (Recommended)
290 Hide build info in client (Recommended)
34 Enable /showname (Recommended)
291 Hide packets from peek (Recommended)
35 Read Data Folder First
36 Read msgstringtable.txt (Recommended)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
41 Disable Nagle Algorithm (Recommended)
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
53 Use Ascii on All LangTypes (Recommended)
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
73 Remove Hourly Announce (Recommended)
90 Enable DNS Support (Recommended)
213 Disable Help Message on Login (Recommended)
231 Remove hardcoded address/port (Recommended)
232 Restore old login packet (Recommended)
244 Disable Cheat Defender Game Guard (Recommended)

 

I've tried turning 53 Use Ascii on All LangTypes (Recommended) off.

 

My client info has:
 

<?xml version="1.0" encoding="euc-kr" ?>
<clientinfo>
	<desc>Ragnarok Online Client Information</desc>
	<servicetype>korea</servicetype>
	<servertype>primary</servertype>
	<connection>
		<display>Local</display>
      	<address>{IP}</address>
      	<port>6900</port>
      	<version>46</version>
      	<langtype>0</langtype>
		<registrationweb>{URL}</registrationweb>
		<loading>
			<image>loading00.jpg</image>
			<image>loading01.jpg</image>
			<image>loading02.jpg</image>
			<image>loading03.jpg</image>
			<image>loading04.jpg</image>
		</loading>
		<yellow>
			<admin>2000000</admin>
			<admin>2000001</admin>
			<admin>2000002</admin>
		</yellow>
   	</connection>
</clientinfo>

 

I cannot use  another langtype and servicetype as it throws nil value in tables.

 

But. English language works perfect.

 

Please help me solving this problem.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

You should enable patch "Always load Korea ExternalSettings lua file". This is allow use all supported langtypes.

Next set langtype what you want for russian language or set servicetype to "russia"

 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, 4144 said:

You should enable patch "Always load Korea ExternalSettings lua file". This is allow use all supported langtypes.

Next set langtype what you want for russian language or set servicetype to "russia"

 

Well I don't have that one patch option available....

It means I should try using different ro:zero client?

Share this post


Link to post
Share on other sites
  • 0

Oh, I see... Somehow missed that ability on website to look if client supports different patches...

 

I guess switching client would be the easiest way and may be most correct one as well.

Share this post


Link to post
Share on other sites
  • 0

look like this patch not works on zero because file named bit different, i will try to fix it...

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, 4144 said:

look like this patch not works on zero because file named bit different, i will try to fix it...

 

Oh that would be wonderful !

 

Otherwise, guess, I'll end up with finding latest zero client files (I'm using one dated back to 21 Dec. 2018)... And attempts to use 2019-05-08a client.

 

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, 4144 said:

can you update nemo from git and check is it works now?

Saw commit before you've written here, pulled, patched client - works like a charm!

 

Thank you for such a blazing fast support!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.