Jump to content

I am stumped :( Don't understand why it works using and not other IPs

Recommended Posts

Hello friend,


I just want to start off by writing that I aspire to be a great support for 3CeAM.

I've gotten the "3CeAM r900 2018-06-21" server package. I'm testing it out on my windows computer before pushing to a Linux server.

Mainly, I just compiled it with Visual C++ 2010 Express. Everything is good with compilation.

I don't think the compiled server is using the MySQL database that I have set up for it.

How would I go about changing the source to read from the database or fix this issue?


Below are some snippets for clarity (because a photo is worth a million words):




import for inter_conf:


import for map_conf:


(purple is WAN IP, ports forwarded and open)


import for char_conf:


(purple is WAN IP, ports forwarded and open)











Please help =(



Thank you,





If I take out:

userid: ragnarok

passwd: ragnarok

, From char and map conf imports,

then the server runs fine, except using s1/p1. Also was not able to access using the client.




UPDATE: SQL Seems to be working fine now. Just cannot connect to the client at the moment.


I switched over to WAMPserver instead of Microsoft MySQL server and imported main.sql from the 3CeAM project.

I also learned about the runserver_sql file XD.



The problem now is this on the client:


I'm gonna be working on this for now. Feel free to help if you would like :)





UPDATE: It works if I place instead of my IP address in the clientinfo.xml file. I have ports forwarded and firewall turned off... So I will be figuring this out now.
Now I'm so stumped... I don't understand why it's not working from my IP address... Is this an issue because of my ISP? I don't even know, HTTP sites seem to work, Ports also report open from other sources. :(

Edited by RimZ

Share this post

Link to post
Share on other sites

As I see you are running server on your pc, so clientinfo would expect for your pc, but for others, your wan ip would work fine.

Try checking in other pc with your wan ip.

Share this post

Link to post
Share on other sites

What client are you using? If its 2018-06-21aRagexeRE make sure your using a sclientinfo.xml file and not clientinfo.xml and double check your entrys in the file. IP and port 6900 should work by default.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.