Jump to content
Ai4rei

RO Open Setup, v2.14.1.425 - last updated 2018/08/28

Recommended Posts

@jabote , i have problem with opensetup/setup.exe 

- there's an error appear when i use 2013 client 20130605 

- [string ''buf'']:1: attempt to index global 'CmdOnOffList' (a nil value)

Share this post


Link to post
Share on other sites

Updated to 2.8.2, fixes a Lua loading bug and adds sanity checks for Lua for people with Lua errors in client (and messed up installs). Also updates Russian and Japanese translation. There is no public 2.8.1, because it was not stable.

 

New bits:

    TEXT_ERROR_INSANE_ENGINE,       "Selected settings engine has determined, that your installation state will interfere with the correct loading and saving of settings.rnrnSee opensetup.log for details."

Share this post


Link to post
Share on other sites

Translating the new string:

 

 TEXT_ERROR_INSANE_ENGINE,      "Se ha observado que el estado de la instalación de Ragnarök Online interfiere en la carga y el guardado correcto de ajustes.rnrnMás detalles en el archivo opensetup.log"
Not quite sure on this one, though.

Share this post


Link to post
Share on other sites

Is there a way to make it work on 2013 client? because when I save the options

 

this one occur(2010?/2011?/2012)

 

CmdOnOffList["/notrade"] = 0
CmdOnOffList["/noshift"] = 0
CmdOnOffList["/noctrl"] = 0
CmdOnOffList["/skillfail"] = 1
CmdOnOffList["/notalkmsg"] = 0
CmdOnOffList["/notalkmsg2"] = 0
CmdOnOffList["/showname"] = 1
CmdOnOffList["/fog"] = 0
CmdOnOffList["/aura"] = 1
CmdOnOffList["/window"] = 0
CmdOnOffList["/miss"] = 1
CmdOnOffList["/q1"] = 0
CmdOnOffList["/q2"] = 0
CmdOnOffList["/effect"] = 1
CmdOnOffList["/bgm"] = 1
CmdOnOffList["/sound"] = 1
CmdOnOffList["/loginout"] = 1
CmdOnOffList["/shopping"] = 0
CmdOnOffList["/stateinfo"] = 1
CmdOnOffList["/snap"] = 0
CmdOnOffList["/itemsnap"] = 0
CmdOnOffList["/skillsnap"] = 1
CmdOnOffList["/hoai"] = 0
CmdOnOffList["/merai"] = 0
CmdOnOffList["/camera"] = 0
CmdOnOffList["/lightmap"] = 1
CmdOnOffList["/monsterhp"] = 1

OptionInfoList["Trilinear"] = 0
OptionInfoList["Bgm_Volume"] = 100
OptionInfoList["Effect_Volume"] = 100
OptionInfoList["AutoOpen1to1Window"] = 1
OptionInfoList["AutoOpen1to1Window_Friend"] = 1
OptionInfoList["PlaySound_Open1to1Window"] = 1
OptionInfoList["Outdoor_ViewLatitude"] = -45.000000
OptionInfoList["Outdoor_ViewDistance"] = 300.000000
OptionInfoList["Indoor_ViewLatitude"] = -45.000000
OptionInfoList["Indoor_ViewDistance"] = 300.000000
OptionInfoList["SkinName"] = "<Basic Skin>"
OptionInfoList["ChannelCopID"] = 0
OptionInfoList["Window_XPos"] = 640
OptionInfoList["Window_YPos"] = 300
OptionInfoList["Simplicity_SkillList"] = 0
OptionInfoList["Show_SkillDescript"] = 0
OptionInfoList["ChangeChatMode"] = 1
OptionInfoList["LockMouse"] = 0
OptionInfoList["ShowBattleFieldIcon"] = 1
OptionInfoList["MouseExclusive"] = 1
OptionInfoList["ISFULLSCREENMODE"] = 0
OptionInfoList["WIDTH"] = 640
OptionInfoList["HEIGHT"] = 480
OptionInfoList["BITPERPIXEL"] = 16
OptionInfoList["DEVICECNT"] = 0
OptionInfoList["MODECNT"] = 0
OptionInfoList["SPRITEMODE"] = 2
OptionInfoList["TEXTUREMODE"] = 2
OptionInfoList["bLockItemDropFromItemWnd"] = 0


 

 

but on 2013 client, its different(2013)

 

 

CmdOnOffList = {
["/battlemode"] = 0,
["/notrade"] = 0,
["/noshift"] = 0,
["/noctrl"] = 1,
["/skillfail"] = 1,
["/notalkmsg"] = 0,
["/notalkmsg2"] = 0,
["/showname"] = 1,
["/fog"] = 1,
["/aura"] = 1,
["/window"] = 0,
["/miss"] = 1,
["/q1"] = 0,
["/q2"] = 0,
["/effect"] = 1,
["/bgm"] = 1,
["/sound"] = 1,
["/loginout"] = 1,
["/shopping"] = 1,
["/stateinfo"] = 1,
["/snap"] = 0,
["/itemsnap"] = 0,
["/skillsnap"] = 1,
["/hoai"] = 0,
["/merai"] = 0,
["/camera"] = 0,
["/btg"] = 1,
["/lightmap"] = 1
}
OptionInfoList = {
Window_XPos = -1,
Window_YPos = -1,
Trilinear = 0,
Bgm_Volume = 100,
Effect_Volume = 100,
AutoOpen1to1Window = 1,
AutoOpen1to1Window_Friend = 1,
PlaySound_Open1to1Window = 1,
Simplicity_SkillList = 0,
Show_SkillDescript = 0,
ChangeChatMode = 1,
LockMouse = 0,
ChannelCopID = 0,
Outdoor_ViewLatitude = -45,
Outdoor_ViewDistance = 400,
Indoor_ViewLatitude = -45,
Indoor_ViewDistance = 300,
SkinName = "<Basic Skin>",
MouseExclusive = 1,

ISFULLSCREENMODE = 0,
WIDTH=800,
HEIGHT=600,
BITPERPIXEL=16
}

 

 

Share this post


Link to post
Share on other sites

There is no difference between those two, except that the later also declares the dictionary if it does not already exist.

 

Also the latest official setup still generates:

OptionInfoList["Bgm_Volume"] = 0OptionInfoList["Effect_Volume"] = 0OptionInfoList["MouseExclusive"] = 0OptionInfoList["ISFULLSCREENMODE"] = 0OptionInfoList["WIDTH"] = 640OptionInfoList["HEIGHT"] = 480OptionInfoList["BITPERPIXEL"] = 16OptionInfoList["DEVICECNT"] = 0OptionInfoList["MODECNT"] = 0OptionInfoList["SPRITEMODE"] = 2OptionInfoList["TEXTUREMODE"] = 2CmdOnOffList["/bgm"] = 0CmdOnOffList["/sound"] = 0CmdOnOffList["/notrade"] = 0CmdOnOffList["/noshift"] = 0CmdOnOffList["/noctrl"] = 0CmdOnOffList["/skillfail"] = 0CmdOnOffList["/notalkmsg"] = 0CmdOnOffList["/notalkmsg2"] = 0CmdOnOffList["/showname"] = 0CmdOnOffList["/fog"] = 0CmdOnOffList["/aura"] = 0CmdOnOffList["/window"] = 0CmdOnOffList["/miss"] = 0CmdOnOffList["/effect"] = 0CmdOnOffList["/shopping"] = 0CmdOnOffList["/stateinfo"] = 0CmdOnOffList["/loginout"] = 0CmdOnOffList["/snap"] = 0CmdOnOffList["/itemsnap"] = 0CmdOnOffList["/camera"] = 0CmdOnOffList["/hoai"] = 0CmdOnOffList["/merai"] = 0CmdOnOffList["/lightmap"] = 0
While the thing you posted, looks way more like decompiled defaults from systemLuaFiles514OptionInfo.lub

 

Thus I do not see a reason for a change.

Edited by Ai4rei

Share this post


Link to post
Share on other sites

ohhhhh now I see.

 

I forgot to test and include this "SystemLuaFiles514OptionInfo.lub" I thot its not included on 2013 but still I tried and it worked.

 

thanks mate

Edited by alohadoubt

Share this post


Link to post
Share on other sites

Updated to 2.9.0, adds troubleshooting option for disabling hardware-accelerated graphics, detection of active mirror drivers (which prevent hardware-acceleration) and various tweaks to visuals and translations.

 

New bits:

    IDCHECKBOX_HELDEVICE,           "Turns hardware-accelerated graphics on and off.nnThis option is only for troubleshooting graphics card issues. When enabled, graphics card will not be utilized by the client for graphics rendering.nNote: This option is NOT recommended for low and average system specification users."    IDINFOICON_VIDEO_MIRRORDRIVER,  "Warning: Mirror driver detected.nnYour graphics card cannot be detected when a mirror driver is active. This can be caused by an active VNC session, remote control server software or malware."    TEXT_DLG_HELDEVICE,             "Disable hardware-accelerated graphics"

Share this post


Link to post
Share on other sites

Translating'em since I've a bit of free time:

 

    IDCHECKBOX_HELDEVICE,           "Activa o desactiva la aceleración de gráficos por hardware.nnUtiliza esta opción solo si tienes problemas con tu tarjeta gráfica. Si está activado, el cliente no utilizará la tarjeta gráfica para renderizar gráficos.nNota: Esta opción NO se recomienda para los usuarios de sistemas de bajas o medias capacidades."    IDINFOICON_VIDEO_MIRRORDRIVER,  "Aviso: Se ha detectado un controlador espejo (mirror driver).nnNo se puede detectar tu tarjeta gráfica si tienes un controlador espejo activo. Esto puede ocurrir a causa de una sesión activa de VNC, software de control remoto o malware."    TEXT_DLG_HELDEVICE,             "Desactivar aceleración de gráficos por hardware"

As I told you, a bit unsure on the mirror drivers one, but the others are good enough.

Share this post


Link to post
Share on other sites

Do you have RO Open setup that can support with latest PlayOnLinux? I already try your latest version but it doesnt work on Ubuntu 13.10 with latest PlayOnLinux.

Share this post


Link to post
Share on other sites

Since PlayOnLinux is uses WINE, it should work. But this is the first time I saw it, I'll look into it.

 

Edit: Hmm, after playing around with it a bit, PlayOnLinux is just a front-end that does simple stuff, the complicated way. OpenSetup runs fine on WINE/PlayOnLinux in a VM when graphics accelerated emulation is off (VM settings) and WINE crashes when graphics acceleration is available. Since I do not have a real machine with linux installed, you should be more specific about what does not work for you.

Edited by Ai4rei

Share this post


Link to post
Share on other sites

Updated to 2.10.0, adds three new in-game commands and improves compatibility and troubleshooting.

 

New bits:

    IDINFOICON_SOUND_MISSINGFILES,  "Warning: Missing or corrupt 'Miles Sound System' files.nnYou are missing some or all of the following files: 'mss32.dll', 'mssfast.m3d', 'mp3dec.asi'. Background music might not work."    IDCHECKBOX_MONSTERHP,           "Turns monster HP display on and off.nnIngame: /monsterhp"    IDCHECKBOX_Q1,                  "Turns F9 mouse-mapping on and off.nEnables you to use a skill assigned to F9 hotkey with a right-click.nnIngame: /quickspell or /q1"    IDCHECKBOX_Q2,                  "Turns F7 and F8 mouse-mapping on and off.nEnables you to use skills assigned to F7 and F8 hotkeys by rolling the mouse wheel up and down respectively.nnIngame: /quickspell2 or /q2"

Share this post


Link to post
Share on other sites

Meep meep

 

    IDINFOICON_SOUND_MISSINGFILES,  "Aviso: Los archivos de "Miles Sound System" faltan o están corruptos.nnFaltan todos o algunos de los siguientes archivos: 'mss32.dll', 'mssfast.m3d', 'mp3dec.asi'. La música del juego podría no funcionar."    IDCHECKBOX_MONSTERHP,           "Activa o desactiva mostrar la barra de vida restante (HP) de los monstruos.nnUso en el juego: /monsterhp"    IDCHECKBOX_Q1,                  "Activa o desactiva el mapeo de F9 al ratón.nPermite utilizar la skill asignada a la tecla F9 con un click derecho.nnUso en el juego: /quickspell o /q1"    IDCHECKBOX_Q2,                  "Activa o desactiva el mapeo de F7 y F8 al ratón.nPermite utilizar skills asignadas a las teclas F7 y F8 desplazando la rueda del ratón hacia arriba y abajo, respectivamente.nnUso en el juego: /quickspell2 o /q2"

Share this post


Link to post
Share on other sites

Updated to 2.10.1, updates Japanese and Spanish translation. No functional changes.

 

great :D mind giving me the missing bits from portuguese so I can translate them?

Share this post


Link to post
Share on other sites

 

 

Well, guys, I need a little bit help here...

 

I was having te same error trying to save changes with OpenSetup (LUA mode, as REG mode is not working with my client).

I'm used the last version available, 2014-08-11opensetup-2.11.0.365.zip.

I have attached 2 screenshots, with my OpenSetup desired configuration and the error I get when I try to save the changes.

Also, there, you can see that systemluafiles514optioninfo.lub file exists. I copied it from a working client folder.

 

 

 

== RO OpenSetup Log ============================================================
[2014-08-20 10:39:17.586][info] Logging started.
[2014-08-20 10:39:17.586]  [info] Version: 2.11.0.365 (built: 53e8e3a9, linker: 6.0, subsystem: 4.0, checksum: 00060923)
[2014-08-20 10:39:17.586]  [info] Operating System: Windows 8  (6.2.9200, Windows NT platform, 32-bit)
[2014-08-20 10:39:17.586]  [info] Memory Utilization: 32%
[2014-08-20 10:39:17.586]  [info] Integrity Level: High
[2014-08-20 10:39:17.586]  [info] Command Line: "C:UsersErijhonDesktopNewClientROopensetup.exe"
[2014-08-20 10:39:17.586]  [Warning] Either there is no config file or it failed to open.
[2014-08-20 10:39:17.609][info] Enumerated 2 DX7 drivers.
[2014-08-20
10:39:17.609]  [info] Driver 'Controlador de pantalla primaria': 13
video modes (5 filtered), 1 hw devices, 1 sw devices
[2014-08-20 10:39:17.609]   [info] HW Device 'Direct3D HAL': Type 1
[2014-08-20 10:39:17.609]   [info] SW Device 'RGB Emulation': Type 0
[2014-08-20 10:39:17.609]  [info] Driver 'Intel® HD Graphics 4000': 13 video modes (5 filtered), 1 hw devices, 1 sw devices
[2014-08-20 10:39:17.609]   [info] HW Device 'Direct3D HAL': Type 1
[2014-08-20 10:39:17.609]   [info] SW Device 'RGB Emulation': Type 0
[2014-08-20 10:39:17.642][info] OnChangeSettingsEngine: LUA
[2014-08-20 10:39:36.521][info] LUA settings engine sanity check started.
[2014-08-20 10:39:36.521]  [info] Checking for 'SystemLuaFiles514OptionInfo.lub'...
[2014-08-20 10:39:36.521]  [info] Default settings file 'SystemLuaFiles514OptionInfo.lub' found. Continuing...
[2014-08-20 10:39:36.521]  [info] Checking for 'savedataOptionInfo.lua'...
[2014-08-20 10:39:36.521]  [info] Settings file 'savedataOptionInfo.lua' found, can be both read and written.
[2014-08-20 10:39:36.521]  [info] Checking for 'savedataOptionInfo.lub'...
[2014-08-20 10:39:36.521]  [Warning] File 'savedataOptionInfo.lub' found.
[2014-08-20 10:39:36.521]  [Error] Remove *.lub files from your savedata or your client won't be able to read settings.
[2014-08-20 10:39:36.521][info] LUA settings engine sanity check stopped.
================================================================================

 

 

What can be happening? Is there something else I can provide you to let you know what's going on?

 

Thank you guys.

 

 

 

EDIT:

Guys, I was so desperate that I couldn't see I was having a different error after having copied the OptionInfo.lub file.

Now the problem was, as the LOG file says, that OptionInfo.lub file was also in SaveData (I don't know how, I never copied it there).

After deleting it, OpenSetup perfectly works.

 

Thanks and sorry for the time I might have taken.

post-6881-0-71101800-1408524367_thumb.jpg

post-6881-0-10778900-1408524521_thumb.jpg

Edited by erijhon

Share this post


Link to post
Share on other sites

Here is the Chinese Simplified translate for OpenSetup

http://pastebin.com/bT5cHSah

Thank you.

 

 

Updated to 2.11.2, adds Simplified Chinese translation, updates Spanish translation and fixes various UI and debug log issues.

 

 

Also read the doc/history.txt if you happen to use Ctrl+Cancel.

 

 

Edit:

Also updated the sources while being at it.

Edited by Ai4rei

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.